Hi David,

It looks like this is an issue with pbs_python and Torque 4.x. There's a
workaround available:

https://oss.trac.surfsara.nl/pbs_python/ticket/40

--nate

On Fri, Nov 18, 2016 at 6:06 AM, David Lee <david....@bristol.ac.uk> wrote:

> Hi Nate,
>
> Thanks for your help. I now get the following error message:
>
>
> (.venv)[galaxy@newblue3 ~]$ python
> Python 2.7.5 (default, Oct 16 2013, 10:52:17)
> [GCC 4.4.7 20120313 (Red Hat 4.4.7-3)] on linux2
> Type "help", "copyright", "credits" or "license" for more information.
> >>> import pbs
> Traceback (most recent call last):
>   File "<stdin>", line 1, in <module>
>   File "/panfs/panasas01/dedicated-galaxy/galaxy/galaxy/.venv/lib/
> python2.7/site-packages/pbs/pbs.py", line 26, in <module>
>     _pbs = swig_import_helper()
>   File "/panfs/panasas01/dedicated-galaxy/galaxy/galaxy/.venv/lib/
> python2.7/site-packages/pbs/pbs.py", line 22, in swig_import_helper
>     _mod = imp.load_module('_pbs', fp, pathname, description)
> ImportError: /panfs/panasas01/dedicated-galaxy/galaxy/galaxy/.venv/lib/
> python2.7/site-packages/pbs/_pbs.so: undefined symbol: _Z13log_availablei
> >>>
>
>
> David
>
> On 17 November 2016 at 17:13, Nate Coraor <n...@bx.psu.edu> wrote:
>
>> Hi David,
>>
>> It sounds like you may have installed the version of pbs-python currently
>> in PyPI, which includes a copy of the Torque C library that is not
>> "manylinux"-safe (it is not backwards compatible to older systems). The
>> solution here is to install pbs-python from its source distribution:
>>
>> 1. Activate Galaxy's virtualenv: `. /panfs/panasas01/dedicated-
>> galaxy/galaxy/galaxy/.venv/bin/activate`
>> 2. `pip uninstall pbs-python`
>> 3. Download/unpack the source tarball from ftp://ftp.surfsara.nl/pub
>> /outgoing/pbs_python.tar.gz
>> 4. In the pbs_python source: `./configure --prefix=/panfs/panasas01/dedi
>> cated-galaxy/galaxy/galaxy/.venv`
>> 5. `make install`
>>
>> --nate
>>
>> On Thu, Nov 17, 2016 at 11:08 AM, David Lee <david....@bristol.ac.uk>
>> wrote:
>>
>>> Hi,
>>>
>>>
>>> I'm trying to install Galaxy version 16.07 on a cluster with the PBS job
>>> scheduler that is using glibc version 2.12. The following error message
>>> suggests that pbs-python needs at least glibc version 2.14 -
>>>
>>>
>>>
>>>     assert pbs is not None, PBS_IMPORT_MESSAGE
>>>
>>> AssertionError: The Python pbs-python package is required to use this
>>> feature, please install it or correct the following error:
>>>
>>> ImportError /lib64/libc.so.6: version `GLIBC_2.14' not found (required
>>> by /panfs/panasas01/dedicated-galaxy/galaxy/galaxy/.venv/lib/py
>>> thon2.7/site-packages/pbs/_pbs.so)
>>>
>>>
>>>
>>> I'm told by an administrator of the cluster that updating to glibc
>>> version 2.14 or higher would require a major overhaul of all the software
>>> on the cluster. Does anybody have a workaround for this problem? Could a
>>> newer version of glibc be used next to version 2.12 just for installation
>>> purposes?
>>>
>>>
>>> Thanks for your help, David
>>>
>>> ___________________________________________________________
>>> Please keep all replies on the list by using "reply all"
>>> in your mail client.  To manage your subscriptions to this
>>> and other Galaxy lists, please use the interface at:
>>>   https://lists.galaxyproject.org/
>>>
>>> To search Galaxy mailing lists use the unified search at:
>>>   http://galaxyproject.org/search/mailinglists/
>>>
>>
>>
>
___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
  https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
  http://galaxyproject.org/search/mailinglists/

Reply via email to