...and indeed adding it to the "whitelist" (~/galaxy_dev/8090/galaxy/lib/galaxy/tools/_init__.py


solves the problem. I can keep 'preserve_python_environment = legacy_only'


I have made a pull request.

Hans-Rudolf

On 03/27/2017 04:38 PM, Hans-Rudolf Hotz wrote:
Hi All

I am in the process of updating our local galaxy servers to release 17.01.

Using the new release, I get the following error, when I try to display
a simple bed file in trackster:


Traceback (most recent call last):
   File
"/***/galaxy_dev/***/galaxy/lib/galaxy/datatypes/converters/interval_to_fli.py",
line 20, in
     from galaxy.datatypes.util.gff_util import
convert_gff_coords_to_bed, GFFReaderWrapper, read_unordered_gtf
ImportError: No module named galaxy.datatypes.util.gff_util



When change 'preserve_python_environment = legacy_only' to
'preserve_python_environment = always' in "galaxy.ini" it works.


Looks like more tools need to be added to the "whitelist" ?


Regards, Hans-Rudolf




___________________________________________________________
Please keep all replies on the list by using "reply all"
in your mail client.  To manage your subscriptions to this
and other Galaxy lists, please use the interface at:
 https://lists.galaxyproject.org/

To search Galaxy mailing lists use the unified search at:
 http://galaxyproject.org/search/

Reply via email to