I am trying to install Galaxy on an ARMV7 architecture Linux server. I ran 
"run.sh" and failed because some of the python eggs could not be fetched. I 
then have a look at "http://eggs.galaxyproject.org/"; and I have realized there 
aren't any armv7 builds for those eggs.

I then decided to build (or scramble) the eggs on my own. I ran 
"scripts/scramble.py" and this also failed with the following message (after 
building a lot of things):

scramble(): Copied egg to:
Traceback (most recent call last):
  File "scripts/scramble.py", line 26, in <module>
    eggs = c.scramble()
  File "/nfs/users/galaxy_dist/lib/galaxy/eggs/scramble.py", line 242, in 
    raise last_exc # only 1 failure out of the crate, be more informative
galaxy.eggs.scramble.ScrambleFailure: run_scramble_script(): Egg build failed 
for bx_python 0.7.1

May I ask what may cause this problem? Have I done anything wrong? Or, is it 
even possible to install Galaxy on ARM architecture Linux?

Many thanks,

The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:


To manage your subscriptions to this and other Galaxy lists,
please use the interface at:


Reply via email to