Hi Michael,

Would you be able to share a history back with these data and provided some notes about the dataset numbers linked to issues you observed for each/steps used to generate the issues? Then Jeremy our trackser designer can help me to find out what is going on. The number of scaffolds may be an issue - but I really cannot say without Jeremy's input.


You can send the link to just him and I. From the history menu (gear icon at top of right-most panel) ? pick Share or Publish, generate the link, and email it directly back off-list.

Sorry that you are having problems, but hopefully this can be worked out,

Jen
Galaxy team

On 3/22/13 1:20 PM, Michael Axtell wrote:
Hi everyone.

I'm having an issue with a wiggle file.  I'm using Trackster on the
public-main instance of Galaxy, with a custom genome build. My wiggle
file fails to be shown. When added to the visualization using the 'add
tracks' dialog, I see the usual hatched gray lines with the message
"processing data, this may take some time".  But then after a few
minutes the track just goes to hatched gray lines with no messages,
and the intensities are never displayed, nor is any error message (or
any message at all, just stuck with the hatched gray lines).

The .wig file has been extensively validated to conform to UCSC spec.
In addition, the same file displays data just fine when loaded into
Broad's IGV. So I'm confident it is formatted correctly.

The custom genome is not a great one .. scaffolds not pseudomolecules,
and there are many thousands of scaffolds in the assembly (scaffold
N50 is 1.3M at scaffold 111 out of ~2,100 scaffolds; total length
~480M). If I slice my problematic wiggle file to only keep
sub-sections of the data, sometimes it works.  I tested a number of
such sub-slices, and some worked and some didn't, as below (the
numbers refer to scaffold numbers in my custom genome):

1-50 : worked
1-100 : worked
1-200 : worked
1-300 : failed
1-400 : failed
1-500 : failed

100-250 : worked
200-300 : worked
300-400 : worked
500-600 : worked

>From the above, it seems possible the error is that Trackster just
doesn't like wig files that exceed a certain number of
chromosomes/scaffolds? Or some sort of data overload issue?

Some other information: This custom genome build works fine on
trackster to visualize several other datasets in gff, gff3, and bed
format. In addition, the problem wiggle file is not so large .. the
full file is only ~48M. It is a fixedStep file with span and step both
equal to 100, and the data are relatively sparse.

If anyone has a clue, let me know .. thanks!


--
Jennifer Hillman-Jackson
Galaxy Support and Training
http://galaxyproject.org

___________________________________________________________
The Galaxy User list should be used for the discussion of
Galaxy analysis and other features on the public server
at usegalaxy.org.  Please keep all replies on the list by
using "reply all" in your mail client.  For discussion of
local Galaxy instances and the Galaxy source code, please
use the Galaxy Development list:

  http://lists.bx.psu.edu/listinfo/galaxy-dev

To manage your subscriptions to this and other Galaxy lists,
please use the interface at:

  http://lists.bx.psu.edu/

To search Galaxy mailing lists use the unified search at:

  http://galaxyproject.org/search/mailinglists/

Reply via email to