Bonsoir,

Chez moi, le commentaire de la ligne n'a pas suffi. Il a fallu que je la 
supprime.

-- 
Charled 

> Le 15 nov. 2014 à 10:25, Michel Verdier <anatole...@gmail.com> a écrit :
> 
> bonjour
> en test, je viens de migrer de .78 en .81 .
> J'ai bien le problème d'affichage des caractères accentués selon le modèle 
> décrit précédemment.(Dans la version .7.8 galette affichait bien é  mais dans 
> phpmyadmin on voyait é)
> 
> Versions serveur (hébergeur O2switch)
> my sql 5.5.40-36.1 - Percona Server (GPL), Release 36.1, Revision 707
> Version du protocole : 10
> Jeu de caractères du serveur : UTF-8 Unicode (utf8)
> cpsrvd 11.44.0.27
> Version du client de base de données : libmysql - 5.1.73
> PHP 5.4.33
> par contre avec  la mise en commentaire de la ligne 125 j'obtiens une page 
> blanche.!!!dès la page d'accueil de galette.
> if ($_type_db === self::MYSQL) {
>   /**                  $_options['charset'] = 'utf8';*/
>                 }
> Je vais tenter l'import/export....
> 
> Michel-Anatole
> 
> 
> Le 11 octobre 2014 08:55, Johan Cwiklinski <jo...@x-tnd.be> a écrit :
>> Salut,
>> 
>> Le 05/10/2014 17:02, Geguce a écrit :
>> >
>> > Idem ici, en version mysql 5.1.73 et php 5.4.30 chez OVH.
>> > Des essais en local avec les dernières versions de Wamp et Xamp donnent
>> > des résultats identiques.
>> > Le fichier en import est bien en UTF-8 (é = é confimé par éditeur hexa
>> > en C3 A9).
>> > Dans phpmy admin c'est bien un é qui est affiché mais galette 8
>> > l'affiche non décodé.
>> >
>> > Dans la version .7.8 galette affichait bien é  mais dans phpmyadmin on
>> > voyait é.
>> > Une chose est certaine, le comportement des 2 versions n'est pas le même
>> > vis à vis du codage ! Lequel a tout juste, je l'ignore en tout cas pour
>> > la migration c'est galère.  Comme solution transitoire j'exporte
>> > iso8859-1 et j'importe en UTF-8 (sauf pour les blobs).
>> > François
>> 
>> Ce qui m'intéresserait, c'est de savoir si la correction que je
>> proposais fonctionne dans ce cas (et aussi si cette correction pose des
>> problèmes à ceux qui n'ont actuellement pas de problèmes !).
>> 
>> Cette modification fait suite à une demande concernant un problème de
>> migration depuis une Galette 0.63. À priori, ça pose plus de problèmes
>> que ça n'en résout (je n'ai quant à moi pas de soucis d'encodage) ; je
>> pense à supprimer la modification, mais je voudrai être certain que ça
>> ne va pas tout casser non plus...
>> 
>> ++
>> --
>> Johan
>> 
>> 
>> _______________________________________________
>> Galette-discussion mailing list
>> Galette-discussion@gna.org
>> https://mail.gna.org/listinfo/galette-discussion
> 
> _______________________________________________
> Galette-discussion mailing list
> Galette-discussion@gna.org
> https://mail.gna.org/listinfo/galette-discussion
_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à