Bonjour Gérard,

Il me semble que j'ai eu un peu le même souci que toi lors d'une réinstallation sur une Tubuline 14.04 serveur.


Je ne suis pas sûr de moi, mais il me semble qu'en fait mon module crypté n'était pas réellement installé.

Est-ce que tu peux vérifier la version de mcrypt (normalement 5.4.6-0ubuntu5) :
dpkg -l | grep php5-mcrypt

Si la commande ne te renvoie rien, installe le module (sudo apt-get install php5-mcrypt)

Est-ce que tu peux vérifier que le module se charge également correctement :
fabrice@smaug:~$ cat /etc/php5/conf.d/mcrypt.ini
; configuration for php MCrypt module
extension=mcrypt.so
fabrice@smaug:~$

vérifie aussi dans les modules disponibles :
fabrice@smaug:~$ ll /etc/php5/mods-available/
total 52
drwxr-xr-x 2 root root 4096 août  17 19:16 ./
drwxr-xr-x 6 root root 4096 août  17 19:12 ../
-rw-r--r-- 1 root root   68 juil.  7 18:51 curl.ini
-rw-r--r-- 1 root root   64 juil.  7 18:51 gd.ini
-rw-r--r-- 1 root root   68 févr. 18  2014 json.ini
-rw-r--r-- 1 root root   58 févr. 22  2011 mcrypt.ini
-rw-r--r-- 1 root root   71 juil.  7 18:51 mysqli.ini
-rw-r--r-- 1 root root   70 juil.  7 18:51 mysql.ini
-rw-r--r-- 1 root root   83 juil.  7 18:51 opcache.ini
-rw-r--r-- 1 root root   66 juil.  7 18:51 pdo.ini
-rw-r--r-- 1 root root   74 juil.  7 18:51 pdo_mysql.ini
-rw-r--r-- 1 root root   76 juil.  7 18:51 readline.ini
-rw-r--r-- 1 root root   68 juil.  7 18:51 tidy.ini

et enfin, il doit être chargé par apache :
fabrice@smaug:~$ ll /etc/php5/apache2/conf.d/
total 8
drwxr-xr-x 2 root root 4096 août  17 20:59 ./
drwxr-xr-x 3 root root 4096 août  17 19:16 ../
lrwxrwxrwx 1 root root 32 août 17 19:16 05-opcache.ini -> ../../mods-available/opcache.ini lrwxrwxrwx 1 root root 28 août 17 19:16 10-pdo.ini -> ../../mods-available/pdo.ini lrwxrwxrwx 1 root root 29 août 17 19:16 20-curl.ini -> ../../mods-available/curl.ini lrwxrwxrwx 1 root root 27 août 17 19:16 20-gd.ini -> ../../mods-available/gd.ini lrwxrwxrwx 1 root root 29 août 17 19:16 20-json.ini -> ../../mods-available/json.ini lrwxrwxrwx 1 root root 31 août 17 20:59 20-mcrypt.ini -> ../../mods-available/mcrypt.ini lrwxrwxrwx 1 root root 31 août 17 19:16 20-mysqli.ini -> ../../mods-available/mysqli.ini lrwxrwxrwx 1 root root 30 août 17 19:16 20-mysql.ini -> ../../mods-available/mysql.ini lrwxrwxrwx 1 root root 34 août 17 19:16 20-pdo_mysql.ini -> ../../mods-available/pdo_mysql.ini lrwxrwxrwx 1 root root 33 août 17 19:16 20-readline.ini -> ../../mods-available/readline.ini lrwxrwxrwx 1 root root 29 août 17 19:16 20-tidy.ini -> ../../mods-available/tidy.ini

Si ce n'est pas le cas, il faut que tu crée le lien vers ton module mcrypt.

De mémoire, c'est le pb que j'avais eu...

Bon courage
Fabrice

Le 05/12/2014 17:38, delafond a écrit :
Bonjour à tous
J'ai la dernière ubuntu, et j'ai voulu mettre à jour une vieille galette en
0.8.1.
La migration des bases s'est bien passée, mais l'installation butte sur mcrypt
: KO ou lieu de OK.

phpinfo me renvoie
mcrypt  Sascha Schumann, Derick Rethans

Le module est installé et activé.

Qu'est-ce que j'ai bien pu lui faire ?

(j'ai aussi dû faire un tas de chmod à la main).

Il faut faire quoi de plus ?

Avec tous mes remerciements anticipés.

Gérard

_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion


_______________________________________________
Galette-discussion mailing list
Galette-discussion@gna.org
https://mail.gna.org/listinfo/galette-discussion

Répondre à