Hi!

On Wed, Jul 01, 2020 at 06:20:22PM -0400, Michael Meissner wrote:
> This patch changes the name of two functions that were added to support power9
> instructions, so that the name of these functions are no longer specific to
> power9.

>       * config/rs6000/rs6000.c (emit_fp_min_max_insn): Rename
>       rs6000_emit_p9_fp_minmax.

You can mention both the old and the new name on the lhs, which is
easier to read (and write!)

> -/* ISA 3.0 (power9) minmax subcase to emit a XSMAXCDP or XSMINCDP instruction
> -   for SF/DF scalars.  Move TRUE_COND to DEST if OP of the operands of the 
> last
> -   comparison is nonzero/true, FALSE_COND if it is zero/false.  Return 0 if 
> the
> -   hardware has no such operation.  */
> +/* Min/max subcase to emit an appropriate instruction for SF/DF scalars on 
> ISA
> +   3.0.
> +
> +   Move TRUE_COND to DEST if OP of the operands of the last comparison is
> +   nonzero/true, FALSE_COND if it is zero/false.  Return 0 if the hardware 
> has
> +   no such operation.  */
>  
>  static int
> -rs6000_emit_p9_fp_minmax (rtx dest, rtx op, rtx true_cond, rtx false_cond)
> +emit_fp_min_max_insn (rtx dest, rtx op, rtx true_cond, rtx false_cond)

Please change the name (and the comment) to make it clear this function
does *not* always emit code, and returns a boolean (an int, maybe change
that too?) saying whether it did do the deed.


Segher

Reply via email to