> Perhaps HLE_ACQUIRE / HLE_RELEASE should be something like HLE_START / > HLE_END instead? Not particularly great names, but at least it avoids > overloading ACQUIRE/RELEASE and thus should make it clearer that you > still need to specify a memory order. > IMHO, this is also not as good, since ACQUIRE/RELEASE reflect actual prefixies names. HLE_START/END may confuse user even more.
I am also, agree with Jakub, such things shouldn't be implied. Going to remove it from patch K