Hi gcc-patches mailing list, Christopher Bazley via Sourceware Forge <[email protected]> has requested that the following forgejo pull request be published on the mailing list.
Created on: 2026-06-23 10:46:06+00:00 Latest update: 2026-06-30 09:49:42+00:00 Changes: 1 changed files, 7 additions, 10 deletions Head revision: chris.bazley/gcc ref horrible_confusion commit 3d813aed51d07b76abdf6ed0c0a1fdb3ee04bd8a Base revision: gcc/gcc-TEST ref trunk commit 6f7c038eee71e519571df5741413f0547fbe85a7 r16-7145-g6f7c038eee71e5 Merge base: 6f7c038eee71e519571df5741413f0547fbe85a7 Full diff url: https://forge.sourceware.org/gcc/gcc-TEST/pulls/182.diff Discussion: https://forge.sourceware.org/gcc/gcc-TEST/pulls/182 Requested Reviewers: 'nelts' is not the number of encoded elements in a VECTOR_CST; it is the number of patterns. Sometimes those interpretations coincide, as in the case of fixed length vector types (for which the number of elements per pattern is one), but not always. 'step' is not the step between the second and third element of a stepped pattern; it is the number of elements per pattern. This has led to confusion on the mailing list. Both variables are hereby renamed. gcc/ChangeLog: * tree.cc (build_vector_from_ctor): Rename variables. Changed files: - M: gcc/tree.cc Christopher Bazley (1): Fix confusing variable names in build_vector_from_ctor gcc/tree.cc | 17 +++++++---------- 1 file changed, 7 insertions(+), 10 deletions(-) Range-diff against v3: 1: 4266718b0e60 ! 1: 3d813aed51d0 Fix confusing variable names in build_vector_from_ctor @@ Commit message * tree.cc (build_vector_from_ctor): Rename variables and refactor assignments. + Co-authored-by: Richard Sandiford <[email protected]> + ## gcc/tree.cc ## @@ gcc/tree.cc: build_vector_from_ctor (tree type, const vec<constructor_elt, va_gc> *v) if (vec_safe_length (v) == 0) -- 2.54.0
