This is a summary of discussions relative to the merge request created by 
Christopher Bazley (chris.bazley) <[email protected]> titled
Fix confusing variable names in build_vector_from_ctor
since its creation.

Description: 'nelts' is not the number of encoded elements in a VECTOR_CST; it
is the number of patterns. Sometimes those interpretations coincide,
as in the case of fixed length vector types (for which the number of
elements per pattern is one), but not always.

'step' is not the step between the second and third element of
a stepped pattern; it is the number of elements per pattern.
This has led to confusion on the mailing list.

Both variables are hereby renamed.

gcc/ChangeLog:

        * tree.cc (build_vector_from_ctor): Rename variables.

CC: [email protected]

The full and up to date discussion can be found at 
https://forge.sourceware.org/gcc/gcc-TEST/pulls/182

The merge request has been closed without being merged directly on the forge 
repository.


On 2026-06-30 11:42:27+00:00, Christopher Bazley (chris.bazley) wrote:

commit d3cd3ff57b6ad4eb434fd75e4e54b2884ab4a44f (HEAD, upstream/master)

Reply via email to