Hi!

On 2026-07-16T19:17:30+0200, Paul-Antoine Arras <[email protected]> wrote:
> On 16/07/2026 16:27, Tobias Burnus wrote:
>> Regarding the documentation (current version at ...)
>> https://gcc.gnu.org/onlinedocs/gcc/OpenMP-and-OpenACC- 
>> Options.html#index-fopenmp-ompt
>> 
>> 
>> First, I find the second part/clause of the first sentence in
>> -fopenmp-ompt-detail in particular confusing:
>> 
>>    Like @option{-fopenmp-ompt}, and additionally emit calls into 
>> libgomp, enabling
>>    OMPT dispatch callbacks that get called at the beginning of each 
>> workshare chunk
>>    for statically scheduled @code{for} and @code{distribute}.  Requires
>>    @option{-fopenmp}.
>> 
>> Maybe: "On top of -fopenmp-ompt, emit additional calls into libgomp,"
>> as minimal change - or even smaller change:
>> "Like -fopenmp-ompt, emit additional calls into libgomp,"
>> 
>> 
>> However, I wonder whether the whole should be completely differently 
>> worded;
>> for instance:
>> 
>> -fopenmp-ompt
>> 
>>    For some OpenMP constructs

Maybe 'certain' instead of 'some'?

>> generate calls before and after the

I like in the current text that we say "calls [into libgomp]", which
intends to help the user understand what kind of calls these are?
Or, even better, as you have it below: "calls into the OpenMP runtime",
to avoid implementor-speak?

>>    region instead of only on region entry.  This improves the OMPT
>>    tracing

Is "OMPT tracing" the correct term to use?

>> at expense of additional calls.  In particular, the
>>    additional calls will be added for static worksharing loops,
>>    static worksharing @code{dispatch}

Shoud this probably be 'distribute' instead of 'dispatch'?

>> and the @code{single},
>>    @code{masked}, and @code{master} construct.
>>    Requires @option{-fopenmp}.
>> 
>> -fopenmp-ompt-details
>> 
>>    Add additional calls into the OpenMP runtime that might affect
>>    the performance

Maybe "might negatively affect performance"?

>> but further improves OMPT tracing. In particular,
>>    dispatch callbacks

Should 'dispatch' get some mark-up here?  Or, prefix with "OMPT"?

>> are generated at the beginning of each workshare 
>> chunk for static worksharing loops and
>>    static worksharing @code{dispatch}.

Again, probably 'distribute' instead of 'dispatch'?

>> This option implies
>>    @option{-fopenmp-ompt}.  Requires @option{-fopenmp}.
>> What do you think?
>
> I am happy to rephrase as you suggest but would like to hear from Thomas 
> (who approved the original patch)

I've got no strong attachment to the current text, so if that's to be
improved, then please go ahead.


Grüße
 Thomas


> and possibly from Sandra (who you 
> already CC'd).
>
> Thanks,
> -- 
> PA

Reply via email to