On 9/7/26 8:43 AM, [email protected] wrote:
From: Kyrylo Tkachov <[email protected]> All three callers of noce_finish_if_conversion bump num_updated_if_blocks right after it returns. Do it in the helper, next to the CFG change it counts. While there, rename cond_exec_changed_p to ifcvt_changed_p. It records that some conversion happened so that if_convert makes another pass, and every successful conversion sets it, including the ones find_if_header reaches through its own success path. The old name suggests only the conditional-execution path does. No functional change. gcc/ChangeLog: * ifcvt.cc (cond_exec_changed_p): Rename to... (ifcvt_changed_p): ...this, and correct its comment. Adjust all uses. (noce_finish_if_conversion): Bump num_updated_if_blocks. (noce_convert_multiple_sets, noce_process_if_block, cond_move_process_if_block): Drop the bump the helper now does. Signed-off-by: Kyrylo Tkachov <[email protected]>
OK jeff
