On 9/15/26 11:49 AM, Stefan Schulze Frielinghaus wrote:
On Mon, Sep 14, 2026 at 05:02:20PM -0400, Vladimir Makarov wrote:
The names of single_reg_class and single_reg_operand_class do not reflect
accurately the return value (type) anymore. I'd simply add suffix _regno for
the both names.
Right, thanks for spotting this! While adding suffix _regno I realized
that function process_single_reg_class_operands could also be renamed to
reflect that it is not only about operands with constraints which have a
single register class associated but also about hard register
constraints.
What about renaming the function to
process_single_reg_constrained_operands
or if we want to keep the current naming scheme to
process_single_reg_class_regno_operands?
I have no preference here. So feel free to use any variant.