On Tue, Oct 23, 2012 at 12:14 PM, Alexander Ivchenko <aivch...@gmail.com> wrote: > Please take a look at the attached patch. > > I changed the asm-pattern implementation according to your recomendation. > Changed the name of feature option from -mfxsave to -mfxsr, as it is in > Intel SDM. Corrected the arguments name in the headers. > > Bootstrap passes
+ case OPT_mxsaveopt: + if (value) + { + opts->x_ix86_isa_flags |= OPTION_MASK_ISA_XSAVEOPT_SET; + opts->x_ix86_isa_flags_explicit |= OPTION_MASK_ISA_XSAVEOPT_SET; + } + else + { + opts->x_ix86_isa_flags &= ~OPTION_MASK_ISA_XSAVEOPT_UNSET; + opts->x_ix86_isa_flags_explicit |= OPTION_MASK_ISA_XSAVEOPT_UNSET; + } + return true; I think that -mxsaveopt should include -mxsave, in the same way that -msse2 includes -msse. Please add this change (also remove -mxsave from sse-X.[c,C] tests). The patch is OK with this change. Please wait for H.J to look if everything is OK w.r.t ABI. Thanks, Uros.