Hi, On Tue, Sep 08, 2026 at 08:28:46AM +0000, Jiang, Haochen via Gcc wrote: > > On Tue, Sep 08, 2026 at 07:46:14AM +0000, Jiang, Haochen via Gcc wrote: > > > I am meeting issues on visiting gcc.gnu.org > > > (including mail archive, Bugzilla, etc.) and sourceware.org > > > (like Binutils archive) with 502 bad gateway. > > > > > > Is the server totally down or it is the issue from my side? > > > > It was a server issue. The httpd server had fallen over (still > > investigating why) and couldn't automatically restart because it tied > > to also setup a listening ssl socket. Which failed because that is > > currently handled by nginx. Told httpd to not try to handle ssl itself > > and everything seems fine again. > > They are working again for me now. > > Thanks for the quick recovery!
To fully close the loop on this incident. What happened was that when nginx was added as frontend to handle all tls (https) traffic as frontend to the httpd (apache) servers, the apache mod_ssl configuration was disabled by removing the ssl.conf file. This morning there was a security update for httpd, which installed an updated mod_ssl and a new ssl.conf file, reenabling the httpd server to listen to port 443. When httpd was reloaded after that update it failed to start up because it couldn't bind to port 443. The "fix" I did this morning was to remove the ssl.conf file again. This would cause the same issue if there was another update for apache mod_ssl. So now ssl is disabled explicitly in the ssl.conf file (which will not get replaced on updates if it already exists). Cheers, Mark
