Hi, I just wanted to check with others whether it was a good idea or not to re-use o_line_recalc() for pins and nets. On one hand, it saves a little code duplication between the objects, however it does seem to break the object abstraction a little.
I've currently got this change made in my git branch, I'm just debating whether to reverse it.. I guess the code now is pretty much only re-calcing within the object's 'own' code, so it is fair enough knowing that a line object representation is underlying. Could we at any stage require pin, bus or net recalc to do anything different to a line recalc? Should we leave the existing functions - even if they are just implemented as wrappers to update the underlying line representation with o_line_recalc()? I'm beginning to favour the last option. It re-adds some stub wrappers, but I think helps to keep things more 'proper'. PS: My git tree is also taking very nice shape to be committed to CVS soon. There are - however, a few behavioural regressions due to implicit grid-snapping when converting between coordinate systems. These need to go... probably replacing them with an explicit grid-snap in world coordinates for those situations which need it (I've not figured where yet!) Peter C. _______________________________________________ geda-dev mailing list [email protected] http://www.seul.org/cgi-bin/mailman/listinfo/geda-dev
