Hi --
I just wanted to check with others whether it was a good idea or not to re-use o_line_recalc() for pins and nets. On one hand, it saves a little code duplication between the objects, however it does seem to break the object abstraction a little.
My opinion -- worth what you paid for it -- is this: It is better to preserve the abstraction and make the code clearer for developers than to do some kind of false code re-use optimization. That is, human understanding is a precious commodity, while computer cycles are dirt cheap. Therefore, I always favor enhancing code understandability for humans over any trivial speed or memory optimization. Just MHO.
My git tree is also taking very nice shape to be committed to CVS soon.
Far out! Thanks for doing all this! Cheers, Stuart _______________________________________________ geda-dev mailing list [email protected] http://www.seul.org/cgi-bin/mailman/listinfo/geda-dev
