I'm not sure the name gegl_graph_create_node is very good either, if
it was possible to come up with a shorter name that describes what it
does I think it would be better. Perhaps gegl_graph_new_node or
gegl_graph_node_new? (only two letters shorter, but I think it conveys
the result just as well).
On 9/1/06, Victor Bogado <[EMAIL PROTECTED]> wrote:
I want to update my binding, so it will match the API in C, the closer
the better. But with "class" as a property it is impossible. This kind
of change, that has a large impact, it is better to be done sooner then
latter, so I would volunteer to change it now and send the diff.
Another option would be to not allow passing additional properties to
the node creation method perhaps turn it into:
GeglNode *gegl_graph_new_node (GeglGraph *graph,
const gchar *operation);
blur = gegl_graph_new_node (graph, "gaussian-blur");
gegl_node_set (blur,
"radius", 1.5,
NULL);
Or even strip even everything but the graph parameter to the function
and always assume that a virgin node has a nop operation associated.)
blur = gegl_graph_new_node (graph);
gegl_node_set (blur,
"operation", "gaussian-blur",
"radius", 1.5,
NULL);
This is probably not a good idea though, since it would increase the
amount of typing needed.
What would you prefer "type" or "operation"? I prefer "operation",
because it is more explicit that this is what the node is doing and also
it is more consistent with the internals, since it is defining what
gegl_operation that node contains.
I prefer "operation" as well.
/Øyvind K.
(I reply back to the mailing-list and not only to you, presuming that
it was a mistake when replying.)
--
«The future is already here. It's just not very evenly distributed»
-- William Gibson
http://pippin.gimp.org/ http://ffii.org/
_______________________________________________
Gegl-developer mailing list
[email protected]
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gegl-developer