-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
http://reviews.gem5.org/r/3673/#review8878
-----------------------------------------------------------



src/sim/process.hh 
<http://reviews.gem5.org/r/3673/#comment7632>

    Can you just rename this to numThreads() instead of making the num_threads 
variable?


- Michael LeBeane


On Oct. 17, 2016, 3:20 p.m., Brandon Potter wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> http://reviews.gem5.org/r/3673/
> -----------------------------------------------------------
> 
> (Updated Oct. 17, 2016, 3:20 p.m.)
> 
> 
> Review request for Default.
> 
> 
> Repository: gem5
> 
> 
> Description
> -------
> 
> Changeset 11695:b71b3bd60a70
> ---------------------------
> syscall_emul: [patch 7/22] remove numCpus method
> 
> The numCpus method is misleading in that it's not really a measure of
> how many CPUs might be executing a process, but how many thread contexts
> are assigned to the process at any given point in time.
> 
> It's nice to highlight this distinction because thread contexts are never
> reused in the same way that a CPU can be reused for multiple processes.
> The reason that there is no reuse is that there is no CPU scheduler for SE.
> 
> The tru64 code intends to use this method and the accompanying contextIDs
> field to support SMT and track the number of threads with some system calls.
> With the up coming clone and exec patches, this paradigm must change. There
> needs to be a 1:1 mapping between the thread contexts and processes so that
> the process state between threads is allowed to vary when needed by Linux.
> This should not break SMT for tru64 if the Process class is refactored so that
> multiple Processes can share state between themselves. The following patches
> will do the refactoring incrementally as features are added.
> 
> 
> Diffs
> -----
> 
>   src/sim/process.hh 4a86763c0b30cccba0f56c7f48637a46a4663b06 
>   src/kern/tru64/tru64.hh 4a86763c0b30cccba0f56c7f48637a46a4663b06 
>   src/arch/alpha/tru64/process.cc 4a86763c0b30cccba0f56c7f48637a46a4663b06 
> 
> Diff: http://reviews.gem5.org/r/3673/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Brandon Potter
> 
>

_______________________________________________
gem5-dev mailing list
gem5-dev@gem5.org
http://m5sim.org/mailman/listinfo/gem5-dev

Reply via email to