Daniel Carvalho has submitted this change. ( https://gem5-review.googlesource.com/c/public/gem5/+/19808 )

Change subject: mem-cache: Fix non-virtual base destructor of Repl Entry
......................................................................

mem-cache: Fix non-virtual base destructor of Repl Entry

ReplaceableEntry contains a virtual method, yet its destructor
was not virtual, causing errors in some compilers.

Change-Id: I13deec843f4007d9deb924882a8d98ff6a89c84f
Signed-off-by: Daniel R. Carvalho <oda...@yahoo.com.br>
Reviewed-on: https://gem5-review.googlesource.com/c/public/gem5/+/19808
Reviewed-by: Nikos Nikoleris <nikos.nikole...@arm.com>
Maintainer: Nikos Nikoleris <nikos.nikole...@arm.com>
Tested-by: kokoro <noreply+kok...@google.com>
---
M src/mem/cache/replacement_policies/replaceable_entry.hh
1 file changed, 9 insertions(+), 6 deletions(-)

Approvals:
  Nikos Nikoleris: Looks good to me, approved; Looks good to me, approved
  kokoro: Regressions pass



diff --git a/src/mem/cache/replacement_policies/replaceable_entry.hh b/src/mem/cache/replacement_policies/replaceable_entry.hh
index dffa4cf..c558bee 100644
--- a/src/mem/cache/replacement_policies/replaceable_entry.hh
+++ b/src/mem/cache/replacement_policies/replaceable_entry.hh
@@ -63,12 +63,15 @@
      */
     uint32_t _way;

-   public:
-     /**
-      * Replacement data associated to this entry.
- * It must be instantiated by the replacement policy before being used.
-      */
-     std::shared_ptr<ReplacementData> replacementData;
+  public:
+    ReplaceableEntry() = default;
+    virtual ~ReplaceableEntry() = default;
+
+    /**
+     * Replacement data associated to this entry.
+     * It must be instantiated by the replacement policy before being used.
+     */
+    std::shared_ptr<ReplacementData> replacementData;

     /**
      * Set both the set and way. Should be called only once.

--
To view, visit https://gem5-review.googlesource.com/c/public/gem5/+/19808
To unsubscribe, or for help writing mail filters, visit https://gem5-review.googlesource.com/settings

Gerrit-Project: public/gem5
Gerrit-Branch: master
Gerrit-Change-Id: I13deec843f4007d9deb924882a8d98ff6a89c84f
Gerrit-Change-Number: 19808
Gerrit-PatchSet: 2
Gerrit-Owner: Daniel Carvalho <oda...@yahoo.com.br>
Gerrit-Reviewer: Daniel Carvalho <oda...@yahoo.com.br>
Gerrit-Reviewer: Nikos Nikoleris <nikos.nikole...@arm.com>
Gerrit-Reviewer: kokoro <noreply+kok...@google.com>
Gerrit-MessageType: merged
_______________________________________________
gem5-dev mailing list
gem5-dev@gem5.org
http://m5sim.org/mailman/listinfo/gem5-dev

Reply via email to