Daniel Carvalho has submitted this change. ( https://gem5-review.googlesource.com/c/public/gem5/+/45430 )

Change subject: sim: Turn InitParamKey into an anonymous namespace
......................................................................

sim: Turn InitParamKey into an anonymous namespace

As part of recent decisions regarding namespace
naming conventions, all namespaces will be changed
to snake case.

pseudo_inst::InitParamKey became an anonymous namespace.

Change-Id: I4a9275a1745e1ed78db0ec99dc91f03ad6d5dfac
Signed-off-by: Daniel R. Carvalho <oda...@yahoo.com.br>
Reviewed-on: https://gem5-review.googlesource.com/c/public/gem5/+/45430
Tested-by: kokoro <noreply+kok...@google.com>
Reviewed-by: Hoa Nguyen <hoangu...@ucdavis.edu>
Maintainer: Gabe Black <gabe.bl...@gmail.com>
---
M src/sim/pseudo_inst.cc
1 file changed, 5 insertions(+), 5 deletions(-)

Approvals:
  Hoa Nguyen: Looks good to me, approved
  Gabe Black: Looks good to me, approved
  kokoro: Regressions pass



diff --git a/src/sim/pseudo_inst.cc b/src/sim/pseudo_inst.cc
index a40c956..11f94f4 100644
--- a/src/sim/pseudo_inst.cc
+++ b/src/sim/pseudo_inst.cc
@@ -81,7 +81,7 @@
  * @note Each key may be at most 16 characters (because we use
  * two 64-bit registers to pass in the key to the initparam function).
  */
-namespace InitParamKey
+namespace
 {

 /**
@@ -97,7 +97,7 @@
  */
 const std::string DIST_SIZE = "dist-size";

-} // namespace InitParamKey
+} // anonymous namespace

 void
 arm(ThreadContext *tc)
@@ -286,11 +286,11 @@

     // Check key parameter to figure out what to return.
     const std::string key_str(key);
-    if (key == InitParamKey::DEFAULT)
+    if (key == DEFAULT)
         return tc->getCpuPtr()->system->init_param;
-    else if (key == InitParamKey::DIST_RANK)
+    else if (key == DIST_RANK)
         return DistIface::rankParam();
-    else if (key == InitParamKey::DIST_SIZE)
+    else if (key == DIST_SIZE)
         return DistIface::sizeParam();
     else
panic("Unknown key for initparam pseudo instruction:\"%s\"", key_str);



6 is the latest approved patch-set.
No files were changed between the latest approved patch-set and the submitted one.
--
To view, visit https://gem5-review.googlesource.com/c/public/gem5/+/45430
To unsubscribe, or for help writing mail filters, visit https://gem5-review.googlesource.com/settings

Gerrit-Project: public/gem5
Gerrit-Branch: develop
Gerrit-Change-Id: I4a9275a1745e1ed78db0ec99dc91f03ad6d5dfac
Gerrit-Change-Number: 45430
Gerrit-PatchSet: 9
Gerrit-Owner: Daniel Carvalho <oda...@yahoo.com.br>
Gerrit-Reviewer: Daniel Carvalho <oda...@yahoo.com.br>
Gerrit-Reviewer: Gabe Black <gabe.bl...@gmail.com>
Gerrit-Reviewer: Hoa Nguyen <hoangu...@ucdavis.edu>
Gerrit-Reviewer: Jason Lowe-Power <ja...@lowepower.com>
Gerrit-Reviewer: kokoro <noreply+kok...@google.com>
Gerrit-MessageType: merged
_______________________________________________
gem5-dev mailing list -- gem5-dev@gem5.org
To unsubscribe send an email to gem5-dev-le...@gem5.org
%(web_page_url)slistinfo%(cgiext)s/%(_internal_name)s

Reply via email to