Brian, thank you for the review & happy holidays. :)

On Sun, Dec 20, 2009 at 4:50 PM, Brian E Carpenter
<[email protected]> wrote:
>
> I have been selected as the General Area Review Team (Gen-ART) reviewer
> for this draft (for background on Gen-ART, please see
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
> Please resolve these comments along with any other Last Call comments
> you may receive.
>
> Document: draft-bryan-metalink-24.txt
> Reviewer: Brian Carpenter
> Review Date: 2009-12-21
> IETF LC End Date: 2010-01-08
> IESG Telechat date:
>
> Summary: Technically ready, but one copyright issue
> --------
>
> Major issues:
> -------------
>
> Note that the inclusion of the pre-5378 disclosure makes it unclear
> whether the RelaxNG code can be licensed by the Trust in the normal way
> (simplified BSD) under the current rules. It would be worth checking on this,
> and maybe including some clarification beyond the standard boilerplate. If
> the RelaxNG code is in fact submitted under RFC5378 conditions, i.e. is
> not derived from older work, stating that fact would probably be enough.
> If the code is in fact subject to RFC3978 conditions, stating that fact would
> be helpful.

The latest revision (-25, unsubmitted) contains changes due to
comments during last call:
http://metalinks.svn.sourceforge.net/viewvc/metalinks/internetdraft/

We use "trust200902" in it. Does that resolve this issue?

> Minor issues:
> -------------
>
> This is a bit picky, but section 4.1.2 contains a series of rules like
> this one:
>
>    o  metalink:file elements MAY contain exactly one metalink:copyright
>       element.
>
> Note that (if parsed rigorously according to RFC2119) this does not forbid an
> element that contains more than one metalink:copyright element. To be 
> rigorous,
> you'd have to add "and MUST NOT contain more than one such element". I'm not 
> sure
> if you want to go there...

Let's be rigorous. I'll make those changes.

Why wouldn't we want to go there?

> Comment:
> --------
>
> I have not checked any of the RelaxNG code from a technical viewpoint.

Julian Reschke recently checked it, and those changes are in the
latest revision.

-- 
(( Anthony Bryan ... Metalink [ http://www.metalinker.org ]
  )) Easier, More Reliable, Self Healing Downloads
_______________________________________________
Gen-art mailing list
[email protected]
https://www.ietf.org/mailman/listinfo/gen-art

Reply via email to