I am the assigned Gen-ART reviewer for
draft-ietf-geopriv-held-measurements-07

For background on Gen-ART, please see the FAQ at
<http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html>.

Please resolve these comments along with any other Last Call comments
you may receive.

Summary: This draft is almost ready for publication as a Proposed
Standard, but I have a few minor comments that you may wish to address.

* Section 5.2

- The Interface-Id option is the DHCPv6 equivalent of the circuit
identifier defined in RFC3046. Please add a reference to Section 22.18
of RFC3315 that describes this option.

- Is there any specific reason that the giaddr is being specified using
the IPv4-mapped IPv6 address format? From my reading giaddr is of type
bt:ipAddressType and it allows specification of both IPv4 and IPv6
addresses natively.

* Section 8.3 Page 44

IPv4-compatible addresses have been deprecated in the IPv6 addressing
architecture (RFC4291) and need not be supported here.

* Section 8.7 Page 53

I think there may be an off-by-one error here.

 <xs:maxInclusive value="268435456"/>

Shouldn't this be

 <xs:maxInclusive value="268435455"/>

so that the largest value will fit in 28 bits?

Thanks
Suresh



_______________________________________________
Gen-art mailing list
[email protected]
https://www.ietf.org/mailman/listinfo/gen-art

Reply via email to