Thanks Suresh. I've made the changes in the -08 that I'm holding for AD go-ahead. I'll try to remember to send you a note when this goes out.
> Summary: This draft is almost ready for publication as a Proposed > Standard, but I have a few minor comments that you may wish to address. > > * Section 5.2 > > - The Interface-Id option is the DHCPv6 equivalent of the circuit > identifier defined in RFC3046. Please add a reference to Section 22.18 of > RFC3315 that describes this option. Got it. Thanks. > - Is there any specific reason that the giaddr is being specified using > the IPv4-mapped IPv6 address format? From my reading giaddr is of type > bt:ipAddressType and it allows specification of both IPv4 and IPv6 > addresses natively. Yeah, that is strange. I'll use a "normal" address. (I think that I was just testing out schema validation in the examples and it leaked out.) > * Section 8.3 Page 44 > > IPv4-compatible addresses have been deprecated in the IPv6 addressing > architecture (RFC4291) and need not be supported here. That's true, but deprecated != MUST NOT use. If it's all the same to you, I'd rather just leave as is. If I were to make a change, it would be to remove acceptance of the dotted quad portion entirely. But I think that the mapped address form is in use. I'd have to check with the working group on that. > * Section 8.7 Page 53 > > I think there may be an off-by-one error here. > <xs:maxInclusive value="268435456"/> Yes, good catch. Either down by one or maxExclusive :) _______________________________________________ Gen-art mailing list [email protected] https://www.ietf.org/mailman/listinfo/gen-art
