Hey Sasha,

Simple patch.  Just change the command line option for consistency to
the config file, variable name, etc.  

Alternately, we could rename everything else from ucast_dump_file to
ucast_file.

Al

-- 
Albert Chu
[EMAIL PROTECTED]
925-422-5311
Computer Scientist
High Performance Systems Division
Lawrence Livermore National Laboratory
>From b10afdf769e73ffa60d123fe8db4063b131a1735 Mon Sep 17 00:00:00 2001
From: Albert L. Chu <[EMAIL PROTECTED]>
Date: Mon, 28 Jul 2008 13:50:27 -0700
Subject: [PATCH] change ucast_file to ucast_dump_file


Signed-off-by: Albert L. Chu <[EMAIL PROTECTED]>
---
 opensm/man/opensm.8.in |    4 ++--
 opensm/opensm/main.c   |    4 ++--
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/opensm/man/opensm.8.in b/opensm/man/opensm.8.in
index a14b5b5..447baed 100644
--- a/opensm/man/opensm.8.in
+++ b/opensm/man/opensm.8.in
@@ -12,7 +12,7 @@ opensm \- InfiniBand subnet manager and administration (SM/SA)
 [\-R <engine name> | \-\-routing_engine <engine name>]
 [\-z | \-\-connect_roots]
 [\-M <file name> | \-\-lid_matrix_file <file name>]
-[\-U <file name> | \-\-ucast_file <file name>]
+[\-U <file name> | \-\-ucast_dump_file <file name>]
 [\-S | \-\-sadb_file <file name>] [\-a | \-\-root_guid_file <path to file>]
 [\-u | \-\-cn_guid_file <path to file>]
 [\-X | \-\-guid_routing_order_file <path to file>]
@@ -131,7 +131,7 @@ This option specifies the name of the lid matrix dump file
 from where switch lid matrices (min hops tables will be
 loaded.
 .TP
-\fB\-U\fR, \fB\-\-ucast_file\fR
+\fB\-U\fR, \fB\-\-ucast_dump_file\fR
 This option specifies the name of the unicast dump file
 from where switch forwarding tables will be loaded.
 .TP
diff --git a/opensm/opensm/main.c b/opensm/opensm/main.c
index 8edce33..ff97e91 100644
--- a/opensm/opensm/main.c
+++ b/opensm/opensm/main.c
@@ -193,7 +193,7 @@ static void show_usage(void)
 	       "          from where switch lid matrices (min hops tables will be\n"
 	       "          loaded.\n\n");
 	printf("-U\n"
-	       "--ucast_file <file name>\n"
+	       "--ucast_dump_file <file name>\n"
 	       "          This option specifies the name of the unicast dump file\n"
 	       "          from where switch forwarding tables will be loaded.\n\n");
 	printf("-S\n"
@@ -579,7 +579,7 @@ int main(int argc, char *argv[])
 		{"routing_engine", 1, NULL, 'R'},
 		{"connect_roots", 0, NULL, 'z'},
 		{"lid_matrix_file", 1, NULL, 'M'},
-		{"ucast_file", 1, NULL, 'U'},
+		{"ucast_dump_file", 1, NULL, 'U'},
 		{"sadb_file", 1, NULL, 'S'},
 		{"root_guid_file", 1, NULL, 'a'},
 		{"cn_guid_file", 1, NULL, 'u'},
-- 
1.5.4.5

_______________________________________________
general mailing list
[email protected]
http://lists.openfabrics.org/cgi-bin/mailman/listinfo/general

To unsubscribe, please visit http://openib.org/mailman/listinfo/openib-general

Reply via email to