Roy Marples wrote:
> config_eth0="1.2.3.4 netmask 255.255.255.0
> 5.6.7.8 netmask 255.255.0.0"
> routes_eth0="1.2.4.0 netmask 255.255.255.0 gw 1.2.3.6
> 5.6.7.9 gw 5.6.7.10
> default gw 1.2.3.1"

If one choose to separate by lines, will tabs or spaces be allowed in
subsequent lines?  Like:

config_eth0="1.2.3.4 netmask 255.255.255.0
             5.6.7.8 netmask 255.255.0.0"
routes_eth0="1.2.4.0 netmask 255.255.255.0 gw 1.2.3.6
             5.6.7.9 gw 5.6.7.10
             default gw 1.2.3.1"

I think this *greatly* improves readability.  Also, the example file
should probably indent for clarity (I know I've talked with you about
this before...).

> address_eth0="1.2.3.4/24 5.6.7.8/16"
> routes_eth0="1.2.4.0/24 1.2.3.6 5.6.7.8 5.6.7.10 default 1.2.3.1"

That's a little confusing, i.e. not being able to see easily where the
pairs are separated.  What about adopting commas and keeping "gw" and
"netmask" (if not CIDR), like:

address_eth0="1.2.3.4/24, 5.6.7.8/16"
routes_eth0="1.2.4.0/24 gw 1.2.3.6, 5.6.7.8 gw 5.6.7.10, default gw 1.2.3.1"

> Or we could adopt the BSD routing notation and do this
> routes_eth0="route_foo route_bar"
> route_foo="1.2.4.0/24 1.2.3.6 metric 5"
> route_bar="default 1.2.3.1"

Hmm, that might be good as an option, as long as the other way is
available too, but I'd keep "gw", etc., perhaps.

> Yes, I've used the same "routes_eth0" variable, but we can change it's syntax 
> based on the existance of address_eth0/config_eth0.
> 
> So what are peoples feelings on this? Are you happy with the names?
> address_eth0?
> addr_eth0?
> addresses_eth0?
> ipaddress_eth0?
> ipaddr_eth0?
> ipaddresses_ath0?
> routes_eth0?
> static_routes_eth0?
> 
> Speak up, or I'll make a decision by myself which will probably be done over 
> the weekend.

I like "ipaddr_eth0" or "ip_eth0", myself.

                -Joe
-- 
gentoo-dev@lists.gentoo.org mailing list

Reply via email to