Hi,

Chí-Thanh Christopher Nguyễn <chith...@gentoo.org>:
>   * Accept numbers as do_set() arguments

 Taken from emacs.eselect

        # target may be specified by its name or its index
        if is_number "${target}"; then
                # numeric index, find the target's name
                targets=( $(find_targets) )
                [[ ${target} -ge 1 && ${target} -le ${#targe...@]} ]] \
                        || die -q "Number out of range: ${1}"
                target=${targets[target-1]}
        fi

 I would love to have more comments to explain in general and
specifically for the structure of MESA_DRIVERS.  The rest of the review
is mostly a matter of style.

> CONFIG_DIR="${EROOT}/usr/share/mesa"

 Maybe something less generic as variable name?  Also the local x, y, z
variables could be named a bit more obvious.

> for y in classic gallium; do
>               z=$(get_drivername ${family} ${y})
>               [ -f ${MESA_DIR}/${z} -o -L ${MESA_DIR}/${z} ] &&
> ret+="${y} " done

 I would welcome more if constructs instead of &&, as it makes the code
more readable.

V-Li

-- 
Christian Faulhammer, Gentoo Lisp project
<URL:http://www.gentoo.org/proj/en/lisp/>, #gentoo-lisp on FreeNode

<URL:http://gentoo.faulhammer.org/>

Attachment: signature.asc
Description: PGP signature

Reply via email to