On Sun, Dec 18, 2005 at 04:50:37PM -0800, Brian Harring wrote: > Yo. > > New one from the looks of it- someone who has time (say, person who > commited it), please iron out the portage.dep_opconvert and > portage_dep.dep_opconvert. > > Naming sucks at the very least, but they look to be a candidate for > refactoring/elimination.
Addendum to this, bug 115983 is a direct result of this- the result is || (a b) , masking of a isn't properly realized. Might be overkill, but after yet another flip through that code, I'm wondering why we haven't gutted that crap. Thoughts? Yes, a refactoring will take a bit of time, and will probably introduce a bug or two, but the code that's there *really* is pretty damn groddy. :) > ~harring
pgpqpWS73dEUF.pgp
Description: PGP signature
