I first discovered this with Seamonkey.  I then tested this with Firefox
and got the same results.  When I go to File and select Print, the print
dialog window pops up for just a second and then the web browser
crashes.  Both seem to use the same print software.  I tried a different
version of Seamonkey but it does the same.  I also tested a fresh
profile of Seamonkey as well, Firefox also.  I don't print from Firefox
much.  Also, if I select Print Preview from the menu, it opens normally
but as soon as I click print, crash.

I then tried a newer unstable version of cups just in case it would
help.  After that, I opened Kwrite and tried to print.  Its print dialog
opened and waited for me to hit print.  LOo did the same.  However, both
of those use a different software or at least they look very different
to print with. 

Usually going back a version or up a version fixes things like this. 
Given that this didn't work in this case, I'm not sure where to go.  Two
versions of Seamonkey and Firefox both crash.  A newer version of cups
and it still crashes.  I did a search on BGO and didn't find anything
except for a fixed version of Chrome which I don't have on here.  I
suspect it uses different software to print anyway.  So no help there. 
Forums had a thread that was from 2010.  It mentioned a USE flag which
cups doesn't even have anymore.  No solution on the forums.

One other thing that may or may not be related.  I did a emerge -e world
a week or so ago.  Before that, I could print fine.  The reason I did
that was because I switched to a new gcc and I just wanted to be sure
everything was stable.  I went from gcc-8 to gcc-9.  It may not have
been needed but it was cold here and I didn't mind the extra heat. 
Plus, it sometimes fixes other quirks I may not even see.  Here is the
info for Seamonkey, Firefox and cups.

root@fireball / # emerge -p seamonkey firefox cups

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   #] www-client/seamonkey- 
USE="chatzilla dbus force-gtk3 gmp-autoupdate ipc jemalloc roaming
startup-notification system-harfbuzz system-icu system-jpeg
system-libevent system-libvpx system-sqlite -calendar -crypt
-custom-cflags -custom-optimization -debug -jack -minimal (-neon)
-pulseaudio (-selinux) (-system-cairo) -test -wifi"
[ebuild   R   ~] www-client/firefox-72.0.2::gentoo  USE="gmp-autoupdate
screenshot startup-notification system-av1 system-icu system-jpeg
system-libevent system-sqlite system-webp -bindist -clang -custom-cflags
-custom-optimization -debug -eme-free -geckodriver -hardened -hwaccel
-jack -lto -pgo -pulseaudio (-selinux) -system-libvpx -test -wayland
-wifi" CPU_FLAGS_X86="-avx2"
[ebuild   R   ~] net-print/cups-2.3.1::gentoo  USE="X dbus pam ssl
threads zeroconf -acl -debug -kerberos -lprng-compat (-selinux)
-static-libs -systemd -usb -xinetd" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 3 packages (3 reinstalls), Size of downloads: 0 KiB
root@fireball / #

I try to set the safest USE flags I can.  I usually follow things I've
read on this list.  If someone thinks changing one will help, I'm
willing to test it.  I can always use my test profile that is blank
anyway.  That way there will be no data loss even in a worst case

This is the gcc-config -l output.

root@fireball / # gcc-config -l
 [1] x86_64-pc-linux-gnu-8.3.0
 [2] x86_64-pc-linux-gnu-9.2.0 *
root@fireball / #

If needed, I could also revert back to gcc-8.  It takes a while but it
is doable as a last resort. 

I'm not sure if the printing is done within Seamonkey itself or if
Seamonkey and Firefox use some common external print software.  I'd
think the later since both behave the same way.  I'm just not sure.

Any ideas or thoughts??



:-)  :-) 

Reply via email to