Harald Welte has posted comments on this change. ( https://gerrit.osmocom.org/13121 )
Change subject: add osmo_use_count API ...................................................................... Patch Set 2: Code-Review+1 (2 comments) https://gerrit.osmocom.org/#/c/13121/2/include/osmocom/core/use_count.h File include/osmocom/core/use_count.h: https://gerrit.osmocom.org/#/c/13121/2/include/osmocom/core/use_count.h@133 PS2, Line 133: talloc_object > It is actually used as talloc context to allocate use count entries (in case > the static entries are […] OK https://gerrit.osmocom.org/#/c/13121/2/include/osmocom/core/use_count.h@150 PS2, Line 150: count > I think it's rather difficult to understand that a given "entry" or "token" > can have multiple "count […] I'm not arguing agains the requirement / use case. I'm just stating that the naming didn't appear vary intuitive to me. What about "use count class" or use count subsystem" or "use count category" rather than "use count entry"? Something like a subsystem which then can have a per-subsystem use count seems more logical/understandable to me. Maybe there's even better naming? -- To view, visit https://gerrit.osmocom.org/13121 To unsubscribe, or for help writing mail filters, visit https://gerrit.osmocom.org/settings Gerrit-Project: libosmocore Gerrit-Branch: master Gerrit-MessageType: comment Gerrit-Change-Id: Ife31e6798b4e728a23913179e346552a7dd338c0 Gerrit-Change-Number: 13121 Gerrit-PatchSet: 2 Gerrit-Owner: Neels Hofmeyr <[email protected]> Gerrit-Reviewer: Harald Welte <[email protected]> Gerrit-Reviewer: Jenkins Builder (1000002) Gerrit-Reviewer: Neels Hofmeyr <[email protected]> Gerrit-Comment-Date: Fri, 08 Mar 2019 11:32:08 +0000 Gerrit-HasComments: Yes Gerrit-HasLabels: Yes
