Hi Steve,

Many thanks for your message.

I checked my installation folder and I do have the folder you mention - it 
contains ffmpeg.exe and AtomicParsley.exe

I should perhaps have mentioned that the download works in that I get a .ts 
file which certainly contains all the audio data as I can open in Audacity and 
export it as a .wav or whatever which is a workaround, but hopefully we can 
find out what the problem is and fix it!

Best wishes


-----Original Message-----
From: Steve Rochford <steve.rochf...@outlook.com> 
Sent: 05 June 2022 17:26
To: Jonathan Bryden <jonat...@speedbird.uk.net>; get_iplayer@lists.infradead.org
Subject: Re: Get_iplayer no longer converts to m4a

That line in the Perl script is part of the run_cmd function which calls all 
the external programs. I think that it will be calling ffmpeg to carry out the 
audio conversion and if that's missing then the conversion will fail.

I don't understand most of the Perl script (there's a reason it's sometimes 
called a "write-only" language) but I think that one of the first thing that 
happens in get_iplayer is a check for ffmpeg so I'm not sure how this is 
succeeding if ffmpeg is missing.

On my install, there's a folder C:\Program Files\get_iplayer\utils\bin which 
contains ffmpeg.exe - do you have a similar folder?


From: get_iplayer <get_iplayer-boun...@lists.infradead.org> on behalf of 
Jonathan Bryden <jonat...@speedbird.uk.net>
Sent: 05 June 2022 16:03
To: get_iplayer@lists.infradead.org <get_iplayer@lists.infradead.org>
Subject: Get_iplayer no longer converts to m4a 
Hi everyone,

Much to my surprise this morning I had the following error message after 
downloading a radio show using get_iplayer:

INFO: Converting to M4A
open3: IO::Pipe: Can't spawn-NOWAIT: No such file or directory at C:\Program 
Files (x86)\get_iplayer\get_iplayer.pl line 2120.

This is not a message I have seen before. Having tried restarting without 
success I upgraded to the latest version (3.30) but I still get the same 

A little internet research has suggested the issue may be related to the PATH 
in the system environment variables though I am not aware of any changes made 
since yesterday.

I have compared the machine to another and there seems to be no difference in 
the portion of the PATH that points to get_iplayer (i.e. ...C:\Program Files 

The PC is running 64bit Windows 7.

I would appreciate any suggestions and am happy to supply any other information 
if required.

Many thanks


get_iplayer mailing list

get_iplayer mailing list

Reply via email to