Thanks so much for all your ideas - unfortunately no success so far.

The same message appear for both TV and radio and both download a .TS file 
before stopping.

With TV programmes I also get the following text 

WARNING: ffmpeg 2.5 or higher is required to convert HLS downloads to MP4
WARNING: Use --raw to bypass MP4 conversion and retain .ts file
WARNING: Use --ffmpeg-force to override checks and force MP4 conversion attempt-

So I tried using the --fmpeg-force command but the result is the same.

Only the first path C:\Program Files (x86)\get_iplayer was in my PATH statement 
but I added :\Program Files (x86)\get_iplayer\utils\bin as suggested and tested 
it with the ffmeg.exe which works.

I have not installed or uninstalled any software or hardware since the problem 
first appeared and there are no files quarantined by my AV software.

This is a mystery to me - any further ideas would be most welcome...

Many thanks


-----Original Message-----
From: xanda escuyer <xa...@gmx.co.uk> 
Sent: 05 June 2022 19:45
To: Jonathan Bryden <jonat...@speedbird.uk.net>; Steve Rochford 
Cc: get_iplayer@lists.infradead.org
Subject: Re: Get_iplayer no longer converts to m4a

Does the same happen with a TV programme or is it radio only?

If the ffmpeg binary is still present under the install directory for 
get_iplayer, then a couple of things to try are:-

1st/ Is the binary in the %PATH% environment variable? Type 'path' from a cmd 
line to see; it ought to contain one or both of the following:-

C:\Program Files\get_iplayer;C:\Program Files\get_iplayer\utils\bin

If it doesn't then try adding them with the command:-

path=%path%;C:\Program Files\get_iplayer;C:\Program Files\get_iplayer\utils\bin;

NB: The second path (the part pointing to \bin) is not added by the installer 
as standard.

2nd/ Is the binary intact? Once the %PATH% variable is setup, running 
ffmpeg.exe (without args) from the prompt should be enough to see.

Does this help?

On Sun, 2022-06-05 at 16:31 +0000, Jonathan Bryden wrote:
> Hi Steve,
> Many thanks for your message.
> I checked my installation folder and I do have the folder you mention
> - it contains ffmpeg.exe and AtomicParsley.exe
> I should perhaps have mentioned that the download works in that I get 
> a .ts file which certainly contains all the audio data as I can open 
> in Audacity and export it as a .wav or whatever which is a workaround, 
> but hopefully we can find out what the problem is and fix it!
> Best wishes
> Jonathan
> -----Original Message-----
> From: Steve Rochford <steve.rochf...@outlook.com>
> Sent: 05 June 2022 17:26
> To: Jonathan Bryden <jonat...@speedbird.uk.net>; 
> get_iplayer@lists.infradead.org
> Subject: Re: Get_iplayer no longer converts to m4a
> That line in the Perl script is part of the run_cmd function which 
> calls all the external programs. I think that it will be calling 
> ffmpeg to carry out the audio conversion and if that's missing then 
> the conversion will fail.
> I don't understand most of the Perl script (there's a reason it's 
> sometimes called a "write-only" language) but I think that one of the 
> first thing that happens in get_iplayer is a check for ffmpeg so I'm 
> not sure how this is succeeding if ffmpeg is missing.
> On my install, there's a folder C:\Program Files\get_iplayer\utils\bin 
> which contains ffmpeg.exe - do you have a similar folder?
> Steve
> From: get_iplayer <get_iplayer-boun...@lists.infradead.org> on behalf 
> of Jonathan Bryden <jonat...@speedbird.uk.net>
> Sent: 05 June 2022 16:03
> To: get_iplayer@lists.infradead.org <get_iplayer@lists.infradead.org>
> Subject: Get_iplayer no longer converts to m4a
> Hi everyone,
> Much to my surprise this morning I had the following error message 
> after downloading a radio show using get_iplayer:
> INFO: Converting to M4A
> open3: IO::Pipe: Can't spawn-NOWAIT: No such file or directory at 
> C:\Program Files (x86)\get_iplayer\get_iplayer.pl line 2120.
> This is not a message I have seen before. Having tried restarting 
> without success I upgraded to the latest version (3.30) but I still 
> get the same problem.
> A little internet research has suggested the issue may be related to 
> the PATH in the system environment variables though I am not aware of 
> any changes made since yesterday.
> I have compared the machine to another and there seems to be no 
> difference in the portion of the PATH that points to get_iplayer (i.e. 
> ...C:\Program Files (x86)\get_iplayer)
> The PC is running 64bit Windows 7.
> I would appreciate any suggestions and am happy to supply any other 
> information if required.
> Many thanks
> Jonathan
> _______________________________________________
> get_iplayer mailing list
> get_iplayer@lists.infradead.org
> https://nam12.safelinks.protection.outlook.com/?url=http%3A%2F%2Flists
> .infradead.org%2Fmailman%2Flistinfo%2Fget_iplayer&amp;data=05%7C01%7C%
> 7C7e2c23257b714430900208da470d159b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%
> 7C1%7C0%7C637900418767008608%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwM
> DAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000%7C%7C%7C&amp;
> sdata=2llPDs5iLE7%2BxWyJe95qVd85qSfT91v0MpBhuFLpWCs%3D&amp;reserved=0
> _______________________________________________
> get_iplayer mailing list
> get_iplayer@lists.infradead.org
> http://lists.infradead.org/mailman/listinfo/get_iplayer

get_iplayer mailing list

Reply via email to