On Sun, Feb 4, 2018 at 8:17 AM, Americo Gobbo <jag.rabi...@gmail.com> wrote:

> Hi Jehan,
>
> On 03/02/2018 22:47, Jehan Pagès wrote:
>
>> Well there is nothing in the command line itself which relates to
>> libexiv2. It looks like there is something wrong in the libtool script
>> wrapper generated by the build system. Delete the file "libtool" which
>> you will find in the root of the git repository. Then run the
>> configure script again (this will create again the libtool wrapper),
>> then make and let's see what happens.
>>
> Is the same behavior... very strange.
>
> libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' or
> unhandled argument '/usr/local/lib/libexiv2.la'
> Makefile:571: recipe for target 'gegl' failed
> make[2]: *** [gegl] Error 1
> make[2]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl/bin'
> Makefile:634: recipe for target 'all-recursive' failed
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'
> Makefile:541: recipe for target 'all' failed
> make: *** [all] Error 2
>
> ---
>
> This is my 'autogen.sh' output:
>
> config.status: creating po/Makefile
>
> Building GEGL with prefix=/opt/gimp-default-master
>
> Optional features:
>   GEGL docs:       yes
>   Build workshop:  no
>   Build website:   yes
>   SIMD:            sse:yes mmx:yes
>   Vala support:    yes
>
> Optional dependencies:
>   asciidoc:        yes
>   enscript:        no  (enscript not found)
>   mrg:             no  (mrg not found)
>   Ruby:            yes
>   Lua:             yes
>   Cairo:           yes
>   Pango:           no  (usable pango not found)
>   pangocairo:      no  (usable pangocairo not found)
>   GDKPixbuf:       no  (gdk-pixbuf not found)
>   JPEG:            yes
>   PNG:             yes
>   OpenEXR:         yes
>   rsvg:            yes
>   SDL:             yes
>   libraw:          no  (libraw library not found)
>   Jasper:          yes
>   graphviz:        no  (graphviz not found)
>   avformat:        no  (sufficiently new libavformat / libavcodec or
> libswcale not found)
>   V4L:             no   (v4l library not found)
>   V4L2:            no  (usable libv4l2 not found)
>   spiro:           yes
>   EXIV:            yes
>   gexiv2:          yes
>   umfpack:         yes
>   TIFF             yes
>   webp:            no  (webp library not found)
>   poly2tri-c:      yes (internal)
>
> We have optional dependencies not resolved... it seems that they are
> 'optional', correct!
> ciao e thanks
> americo
>
> Americo,

You're going to have serious issues since pango, gdk-pixbuf are not found
on your system. This is really strange.

Partha
_______________________________________________
gimp-developer-list mailing list
List address:    gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list

Reply via email to