On 02/02/2018 09:13 PM, Americo Gobbo wrote:
Hi All,
I have upgrade my system to ubuntu gnome 16.04.3 and I have tried again compile GEGL.


On 02/03/2018 07:37 PM, Americo Gobbo wrote:
-I/opt/gimp-default-master/include/gio-unix-2.0/ -I/opt/gimp-default-master/include/glib-2.0 -I/opt/gimp-default-master/lib/glib-2.0/include

-I/usr/include/json-glib-1.0 -I/opt/gimp-default-master/include/babl-0.1

-I/opt/gimp-default-master/include/libpng16 -I/opt/gimp-default-master/include -I/opt/gimp-default-master/include/glib-2.0 -I/opt/gimp-default-master/lib/glib-2.0/include  -std=gnu99 -fPIC -mmmx

-L/opt/gimp-default-master/lib -Wl,--export-dynamic -lgmodule-2.0


-L/opt/gimp-default-master/lib -lpng16 -lspiro -lm -L/opt/gimp-default-master/lib -lgexiv2 -lgobject-2.0 -lglib-2.0 -o gegl

libtool:   error: cannot find the library '/usr/local/lib/libexiv2.la' or unhandled argument '/usr/local/lib/libexiv2.la'

make[1]: Leaving directory '/home/jag/devel/gimp-default-master-/gegl'

Looking at the above lines, I'm confused. It looks like some stuff is installed in /opt/gimp-default-master, other stuff in /usr/local, and yet other stuff in /home/jag/devel/gimp-default-master.

Would it be easier to install *all* the requirements for installing babl/GEGL/GIMP (the requirements that can't be installed from the usual Ubuntu 16.04.3 repositories) in just one place, for example in an "install" folder in /home/jag/devel/gimp-default-master"? That way there'd be no need to tell babl or GEGL or GIMP to go "here for this stuff, there for some other stuff".

Anyway, something I'd wished I'd known a long time ago, all the specific requirements for GIMP from git are in the "configure.ac" file in the top-level folder for the GIMP git code, which makes it easy to see which Ubuntu-supplied software is current enough, and which software needs a more current version installed in the babl/GEGL/GIMP install prefix. Here's the list as of this morning:

# required versions of other packages
m4_define([babl_required_version], [0.1.42])
m4_define([gegl_required_version], [0.3.29])
m4_define([glib_required_version], [2.54.2])
m4_define([atk_required_version], [2.2.0])
m4_define([gtk_required_version], [2.24.10])
m4_define([gtk_win32_recommended_version], [2.24.32])
m4_define([gdk_pixbuf_required_version], [2.30.8])
m4_define([cairo_required_version], [1.12.2])
m4_define([cairo_pdf_required_version], [1.12.2])
m4_define([pangocairo_required_version], [1.29.4])
m4_define([fontconfig_required_version], [2.2.0])
m4_define([fontconfig_win32_recommended_version], [2.11.1])
m4_define([freetype2_required_version], [2.1.7])
m4_define([harfbuzz_required_version], [0.9.19])
m4_define([gtkdoc_required_version], [1.0])
m4_define([webkit_required_version], [1.6.1])
m4_define([alsa_required_version], [1.0.0])
m4_define([rsvg_required_version], [2.40.6])
m4_define([wmf_required_version], [0.2.8])
m4_define([pygtk_required_version], [2.10.4])
m4_define([pycairo_required_version], [1.0.2])
m4_define([poppler_required_version], [0.44.0])
m4_define([poppler_data_required_version], [0.4.7])
m4_define([libgudev_required_version], [167])
m4_define([gexiv2_required_version], [0.10.6])
m4_define([libmypaint_required_version], [1.3.0])
m4_define([lcms_required_version], [2.8])
m4_define([libpng_required_version], [1.6.25])
m4_define([liblzma_required_version], [5.0.0])
m4_define([openexr_required_version], [1.6.1])
m4_define([gtk_mac_integration_required_version], [2.0.0])
m4_define([intltool_required_version], [0.40.1])
m4_define([perl_required_version], [5.10.0])
m4_define([python2_required_version], [2.5.0])
m4_define([webp_required_version], [0.6.0])

Here's the same list for GEGL, but of course if GIMP needs a newer version than GEGL, use the version given in GIMP's list:

# required versions of external libraries
m4_define([babl_required_version], [0.1.42])
m4_define([cairo_required_version], [1.12.2])
m4_define([exiv2_required_version], [0.25])
m4_define([gdk_pixbuf_required_version], [2.32.0])
m4_define([introspection_required_version], [1.32.0])
m4_define([glib_required_version], [2.44.0])
m4_define([graphviz_required_version], [0.0.0])
m4_define([jasper_required_version], [1.900.1])
m4_define([lcms_required_version], [2.8])
m4_define([lensfun_required_version], [0.2.5])
m4_define([librsvg_required_version], [2.40.6])
m4_define([libv4l2_required_version], [1.0.1])
m4_define([lua_required_version], [5.1.0])
m4_define([openexr_required_version], [1.6.1])
m4_define([libraw_required_version], [0.15.4])
m4_define([pango_required_version], [1.38.0])
m4_define([png_required_version], [1.6.0])
m4_define([sdl_required_version], [1.2.0])
m4_define([libtiff_required_version], [4.0.0])
m4_define([webp_required_version], [0.5.0])
m4_define([poly2tri-c_required_version], [0.0.0])
m4_define([pygobject2_required_version], [2.26])
m4_define([pygobject3_required_version], [3.2])
m4_define([vapigen_required_version], [0.20.0])
m4_define([libavformat_required_version], [55.48.100])
m4_define([libavcodec_required_version], [55.69.100])
m4_define([libswscale_required_version], [2.6.100])

Best,
and my apologies if none of the above is helpful!
Elle
_______________________________________________
gimp-developer-list mailing list
List address:    gimp-developer-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-developer-list
List archives:   https://mail.gnome.org/archives/gimp-developer-list

Reply via email to