Hi Adam,

"Adam D. Moss" <[EMAIL PROTECTED]> writes:

> Thanks.  Well, 6 hours later I have gimp 1.3 built!  Yay!
> Naturally, it crashes on startup.  Boo!  After trying to
> 'ok' the second page of the gimp user installation wizard
> I get this:
> mct:~> gimp-1.3
> gimp-1.3: fatal error: Segmentation fault
> gimp-1.3 (pid:9613): [E]xit, [H]alt, show [S]tack trace or [P]roceed: s
> #0  0x40550924 in g_on_error_stack_trace (prg_name=0xbffff833
> "gimp-1.3")
> #1  0x4055083e in g_on_error_query (prg_name=0xbffff833 "gimp-1.3")
> #2  0x80816cd in gimp_eek (reason=0x819cea8 "fatal error", 
> #3  0x808162e in gimp_fatal_error (fmt=0x40676e90 "Segmentation fault")
> #4  0x8081225 in gimp_sigfatal_handler (sig_num=11) at main.c:501
> #5  0x405c7858 in sigaction () from /lib/libc.so.6
> #6  0x40564428 in g_main_context_iterate (context=0x8243550, block=0, 
> #7  0x40564635 in g_main_context_pending (context=0x0) at gmain.c:2261
> #8  0x40129e8e in gtk_events_pending () at gtkmain.c:863
> #9  0x808e980 in user_install_continue_callback (widget=0x825e568, 

well, naturally I can't reproduce this here. I've removed my
~/.gimp-1.3 directory and was able to finish user installation w/o a
problem. I can't see anything wrong with the code either:

      while (gtk_events_pending ())
        gtk_main_iteration ();

that might be deprecated API (I haven't checked)  but it should work
in any case.

> And now I'm going to go seek out some beer and friends to
> commiserate with...

have fun. I'd really like to help you get a working gimp-1.3
installation, so please try to investigate the problem further and
report back.

Salut, Sven

Gimp-developer mailing list

Reply via email to