Hi,

[EMAIL PROTECTED] (Tino Schwarze) writes:

> I'd like to comment on bug #79754. Some time ago I built a GIMP 1.2.2
> RPM for SUSE. There was a gimp-fontset.patch included:
> 
> --- app/text_tool.c.orig        Sat Jan 27 16:29:16 2001
> +++ app/text_tool.c     Sat Jan 27 16:31:50 2001
> @@ -607,7 +607,7 @@
>    gdk_error_warnings = 0;
>    gdk_error_code = 0;
>  #ifndef GDK_WINDOWING_WIN32
> -  font = gdk_font_load (fontname);
> +  font = gdk_fontset_load (fontname);
>    if (!font)
>      {
>        g_message (_("Font '%s' not found."), fontname);
> @@ -838,7 +838,7 @@
>    gdk_error_warnings = 0;
>    gdk_error_code = 0;
>  #ifndef GDK_WINDOWING_WIN32
> -  font = gdk_font_load (fontname);
> +  font = gdk_fontset_load (fontname);
>    if (!font)
>      return FALSE;
> 
> The problem was: It did not work. If I entered umlauts into the
> (dynamic) text tool, the text got truncated there (although they showed
> up fine in the preview). (I used the "C" locale, not de_DE or
> something).
> 
> I talked a bit with Daniel Egger but we didn't come to a clear solution.
> If I find the time, I'll check out CVS today and give check whether the
> problem persists.
> 
> I tracked down the problem to gdk_measure_text which called
> XmbTextExtens which in turn returned the wrong width (truncated at first
> umlaut).
> 
> I'm just telling that story to point out that fontset support might be a
> hairy issue and hard to get right.

Thanks. Such comments are exactly what I had in mind when I sent the
mail. Could you please also attach this comment to the bug-report so
it doesn't get lost.


Salut, Sven
_______________________________________________
Gimp-developer mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-developer

Reply via email to