"William Skaggs" <[EMAIL PROTECTED]> writes:

> Nice to see the first tarball of the new round come out.

Ughh, We are running on a temporary server and I wanted to let the
mirrors pick up the package before announcing it here. You could have
waited for the announcement at least :(

>  There are a couple of things I notice, though.  First, the INSTALL
> file says:
>   2. You need to have installed GTK+ version 2.2.2 or better. Do not
>   try to use an older GTK+ version (1.2.x), it will not work.
>   GTK+-2.2 itself needs recent versions of GLib, Pango and ATK.
>   Sources for these can be grabbed from ftp://ftp.gtk.org/.
>   GTK+-2.x and friends can be installed side by side with GTK+-1.2.
> But this is incorrect, I believe -- GTK+2.4 is now needed.

Fixed in CVS.
> Second, it is good that a strong warning about using a separate
> prefix appears, but I fear that people will nevertheless miss it and
> then be annoyed about having trashed their existing Gimp 2.0
> installations.  Would it be too obnoxious to alter configure.sh so
> that it does not work unless --prefix=xxx is explicitly specified?

I don't think this could be done and I also don't think it's a good
idea to fiddle with autoconf internals. People who install a
development version with reading INSTALL or README (which both contain
the warning) IMHO deserve to have their installation screwed up badly.
And actually, there aren't many files clashing. gimp-2.0 will continue
to work even after you installed gimp-2.1 into the same prefix. It's
just compilation of plug-ins against gimp-2.0 that will break.

Gimp-developer mailing list

Reply via email to