$ automake --version
Can't locate Automake/Struct.pm in @INC (@INC contains: /usr/share/automake-1.8 
/usr/lib/perl5/5.6.1/msys /usr/lib/perl5/5.6.1 

/usr/lib/perl5/site_perl/5.6.1/msys /usr/lib/perl5/site_perl/5.6.1 
/usr/lib/perl5/site_perl .) at /home/ted/src/bin/automake line 47.
BEGIN failed--compilation aborted at /home/ted/src/bin/automake line 47.

Maybe I need to install something called Struct to perl.
I assume it's Class::Struct that I need and not one of
Inline::Struct, DynaLib::Struct, Win32::API::Struct,
Inline::SLang::Struct, SOAP::Struct, Class::MakeMethods::Template::Struct 
WDDX::Struct, or some other Struct.

perl -MCPAN -e 'install Struct'
tries to run ftp, but Windows ftp pops up ftp in another console window
where it's obvious that stdio is not being used.  

There are two ftp programs in /bin, one called /bin/ftp and the other 

mv /bin/ftp /bin/ftp.bak
solves that problem, but trying perl -MCPAN produces the following message,
  Please, install Net::FTP as soon as possible. CPAN.pm installs it for you
  if you just type
      install Bundle::libnet

so the following commands seem appropriate:
perl -MCPAN -e 'install Bundle::libnet'
perl -MCPAN -e 'install Class::Struct'

This gives the following error:

The most recent version "0.63" of the module "Class::Struct"
comes with the current version of perl (5.8.5).
I'll build that only if you ask for something like
    force install Class::Struct

perl -MCPAN -e 'force install Class::Struct'  
gives the same message.

Stuck for the moment.  Any ideas?  
Maybe I don't need this version of automake to build GIMP on mingw?
Maybe I should back up and try Cygwin instead?

Juno Platinum $9.95. Juno SpeedBand $14.95.
Sign up for Juno Today at http://www.juno.com!
Look for special offers at Best Buy stores.
Gimp-developer mailing list

Reply via email to