GG wrote: [******]

I agree that it would be helpful to have more guidance
for new contributors, but my own experience is that most
of my trouble has come from trying to understand the
high-level structure -- the overall architecture, the
core objects and the principles for using them.  The
low-level thing that has caused me the most difficulty is
signals -- knowing when one is going to be emitted and
what is going to happen as a result -- because this is
often not apparent from the source code.

On the question of longer lines, I disagree.  For
comments it doesn't really matter, but I find consecutive
long lines of code extremely difficult to read.  Also I
often work on code with multiple Emacs windows open side 
by side, and in that scenario even with a good modern monitor
it creates difficulties if the code is wide.

There is no question that it is helpful to use good variable
names, and lots of the "old" code could definitely be improved
in this respect.  People's opinions about specifics may vary,
though.  I myself think "bytes" is fine if it is used consistently
with always the same meaning, and "bpp" is fine, but "bytes_pp"
impairs readability.

I also think that, strategically speaking, it is best to focus
these sorts of improvements on code that needs maintainance for
other reasons, because experience shows that even something as
seemingly harmless as renaming variables often causes accidental

Best wishes,
  -- Bill

______________ ______________ ______________ ______________
Sent via the CNPRC Email system at

Gimp-developer mailing list

Reply via email to