On 03/16/2011 04:38 AM, Nils Philippsen wrote:
> On Wed, 2011-03-16 at 02:13 -0700, Patrick Horgan wrote:
>> There was a recent update to configure.ac:
>>
>> commit 514a5548cdcaf5a60f47067007936dc58055132b
>> Author: Michael Natterer<mi...@gimp.org>
>> Date:   Mon Mar 7 15:43:45 2011 +0100
>>
>>       configure: require GLib>= 2.28.1
>>
>> I have a recent ubuntu and it has 2.26.x and so GIMP won't configure and
>> build anymore.  (Well, changing the 28 to 26 makes it "build", except
>> there are 2 unresolved references, g_list_free_full, and
>> g_slist_free_full.  I don't suppose there's a workaround, huh?  I wasn't
>> wanting to build my own glib.
> I just chatted up Mitch about this, we'll soon depend on gtk+-2.24
> anyway so reverting the change that led up to this wouldn't help really.
So I hope that soon would be past GIMP 2.8 so distributions can accept 
it without having to update glib.  It would make it a lot easier to get 
in.  For me not an issue, building glib is easy.  I just worry about 
whether we're getting too far ahead of the rest of the world.

Patrick

_______________________________________________
Gimp-developer mailing list
Gimp-developer@lists.XCF.Berkeley.EDU
https://lists.XCF.Berkeley.EDU/mailman/listinfo/gimp-developer

Reply via email to