On  1 Oct, Marc Lehmann wrote:

>> I haven't fixed yet the GIMP Perl plugins installation, please could
>> anyone fix it or tell me a workaround?
 
> The README.perl suggests PREFIX= for just this case. Daniel Egger
> could probably get more info as he works for suse and suse has quite a
> few perl packages in rpm format (includign gimp-perl).

 We build the gimp-perl plugin from the CPAN sources and disable it in
 the GIMP distribution because it makes too much problems there especially
 on recent SPARCs, alphas and ia64. We don't use the BuildRoot features
 of RPM however because it has some issues with Perl which Marco also
 found.... :)

 The important section from the gimp-perl package looks like this:

%build
CFLAGS="-DGIMP_ENABLE_COMPAT_CRUFT" perl Makefile.PL 
make 

%install
eval `perl -V:installarchlib` 
rm -f $installarchlib/perllocal.pod
make install
install -d /var/adm/perl-modules
mv $installarchlib/perllocal.pod /var/adm/perl-modules/gimpperl
%{?suse_check}

 whereas the necessary BuildRoot stuff from the MIME-Base64 Perl package
 looks like this:

%build
perl Makefile.PL
make

%install
rm -rf $RPM_BUILD_ROOT
eval `perl -V:installarchlib`
install -d $RPM_BUILD_ROOT/$installarchlib
make PREFIX=$RPM_BUILD_ROOT/usr \
     INSTALLMAN1DIR=$RPM_BUILD_ROOT/%{_mandir}/man1 \
     INSTALLMAN3DIR=$RPM_BUILD_ROOT/%{_mandir}/man3 \
     install
install -d $RPM_BUILD_ROOT/var/adm/perl-modules
mv $RPM_BUILD_ROOT/$installarchlib/perllocal.pod $RPM_BUILD_ROOT/var/adm/perl-mo
cd $RPM_BUILD_ROOT/usr/lib/perl5/site_perl/5.*/*-linux/auto/MIME/Base64
cat .packlist | sed s:$RPM_BUILD_ROOT:: | sort -u > .packlist.n
mv .packlist.n .packlist
cd $RPM_BUILD_ROOT/var/adm/perl-modules/
cat MIME-Base64 | sed s:$RPM_BUILD_ROOT:: > MIME-Base64.n
mv MIME-Base64.n MIME-Base64

 Using PREFIX for installation doesn't seem to work for all packages,
 though...

-- 

Servus,
       Daniel

Reply via email to