Ulf-D. Ehlert skreiv:
> Kolbjørn Stuestøl (Wednesday, 10. February 2010)
>> Hi list
>> I have updated my copy of Cygwin with some new packages and after a
>> couple of evenings all "git" and "make" commands works fine ---
>>  except for the "make html-xx" (and perhaps make pdf-xx. Not tried
>>  as it did not worked before the updating either).
>> When running
>> $ make html-nn
>> I get these error messages:
>> *** Making html for nn ...
>> I/O error : Attempt to load network entity
>> http://docbook.sourceforge.net/release/xsl/current/xhtml/chunk.xsl
>> warning: failed to load external entity
>> "http://docbook.sourceforge.net/release/xsl/current/xhtml/chunk.xsl
>> " compilation error: file stylesheets/plainhtml.xsl line 8 element
>>  import xsl:import : unable to load
>> http://docbook.sourceforge.net/release/xsl/current/xhtml/chunk.xsl
>> make: *** [html/nn/index.html] Error 5
> It looks like your docbook-xsl package is not properly configured. 
> Then xsltproc can't find out where the actual "chunk.xsl" is. So you 
> should check your XML catalog(s).
> For example, my docbook-xsl package contains an XML catalog file 
> /etc/xml/docbook-xsl.xml (which is referred to by the main XML catalog 
> file) with the lines
>     <rewriteSystem
>     systemIdStartString="http://docbook.sourceforge.net/release/xsl/current";
>     rewritePrefix="file:///usr/share/xml/docbook/stylesheet/nwalsh/1.75.2"/>
> and
>     <rewriteURI
>     uriStartString="http://docbook.sourceforge.net/release/xsl/current";
>     rewritePrefix="file:///usr/share/xml/docbook/stylesheet/nwalsh/1.75.2"/>
> (I guess the second line is important),
> so xsltproc actually reads 
>     /usr/share/xml/docbook/stylesheet/nwalsh/1.75.2/xhtml/chunk.xsl
> when importing ".../chunk.xsl" in "stylesheets/plainhtml.xsl line 8".
> Ulf
Thank you, Ulf
I think you are leading me on the right path :-)
I have to dig a bit deeper in this material. Finding out where the 
different files are stored etc. to set the addresses. I think I have 
mashed my Cygwin copy a bit up by partially using automatic setup and 
partially done it by hand the Unix way.
I bet there is a solution, I only have to find it.
Gimp-docs mailing list

Reply via email to