I did it the easy way by cloning a new local copy and then added my translated files, git commit and then git push. Now it works as normal.

Den 14.01.2016 16:02, Kolbjørn Stuestøl skreiv:
Thank you Marco. You are always helpful.
I just got an answer on the other list to. Suggesting starting all over again from a new clone. I think I'll do that before I try your suggestion. To me who know very little about the git commands, this is a safer method. But have to wait until later this night. Other things to do in the meantime.

Den 13.01.2016 23:45, Marco Ciampa skreiv:
On Wed, Jan 13, 2016 at 09:48:26PM +0100, Kolbjørn Stuestøl wrote:
As this question is related to the GIMP UI I posted this in
developers forum (gimp-developer-l...@gnome.org) a couple of days
ago but get no answers. Hoping someone in this list are able to
answer me. I guess it has something with "git config" to do.

When committing my translation all looks well on my local copy. But
my translations do not shows up in the
https://git.gnome.org/browse/gimp/ site. Where is my translations

I downloaded my copies using "git clone <ssh://[my
Updated and translated some po files and then:

    $ git commit -m "Updated Norwegian (nn) translations"
    [master 7b2f8a5] Updated Norwegian (nn) translations
      5 files changed, 13801 insertions(+), 9813 deletions(-)
      mode change 100644 => 100755 po-plug-ins/nn.po
      mode change 100644 => 100755 po-python/nn.po

My local git log shows:

    $ git log
    commit 7b2f8a5cff63bdea6db76b642445cfb8a11d1b0b
    Author: kolbjoern <kolbjo...@git.gnome.org>
    Date:   Mon Jan 11 21:19:53 2016 +0100

         Updated Norwegian (nn) translations

    commit 97ea600623b780fc9dba4abbaa45db44e626a10e
    Author: Michael Natterer <mi...@gimp.org>
    Date:   Mon Jan 11 20:35:32 2016 +0100

         app: s/Default/Color/ in the testing icon theme Makefile rules

My commit must obviously go somewhere but I have no idea where.
How to get it to upload (git push) to the correct gimp repository?

Last time I uploaded my files (2016.01.07) I got the error message
"remote: error: refname 'GIMP_HELP_2_8_2' is ambiguous" (but the
"git push" succeeded) and I was told to run "git config --global
push.default matching" and/or
"git config --global push.default simple". I did this in that order.
No error messages.
Strange because:

1) looking on the commit 97ea600623b780fc9dba4abbaa45db44e626a10e you are
    currently on master

2) if you do a log and you see your changes you made that seems to me
    that you did not push that commit at all. You probably are in a
    detached HEAD state.

Trivial and primitive way to exit this situation.

1) save your translated files somewhere out of git repo

2) reset --hard your git to commit 97ea600623b780fc9dba4abbaa45db44e626a10e

3) git pull

4) replace files with your saved copies

5) commit & push


gimp-docs-list mailing list

gimp-docs-list mailing list

Reply via email to