On Tue, Oct 2, 2012 at 9:37 AM, minhsien0330 <minhsien0...@gmail.com> wrote:
> 2012/10/1 Jehan Pagès <jehan.marmott...@gmail.com>
>> Are you using the linuxwacom X driver (which has some support for
>> Waltop tablets, I see:
>> http://linuxwacom.git.sourceforge.net/git/gitweb.cgi?p=linuxwacom/xf86-input-wacom;a=blob;f=src/wcmUSB.c;h=9f327ba6b0210a04933da22861750d304d7edb86;hb=HEAD#l172
>> and your tablet is apparently a Walcom one sold under another brand)
>> or the X driver from the vendor itself
>> (http://www.waltop.com.tw/download.asp?lv=0&id=2 which is apparently a
>> fork off of linuxwacom 0.8.4, according to linuxwacom sources)?
>> Note that I don't see your device (0x5a) in linuxwacom list. So I
>> guess the answer is that you are using the vendor driver. Just to be
>> sure though, would be worth checking.
> Dear Jehan:
> I did not install the driver from the vendor or xserver-xorg-input-wacom, I
> am not sure it's wacom driver or not.
> The dmesg and Xorg.0.log seems not talking about this, do you know how to
> check the driver?

There is this other project, DIGImend, that was linked from
This project works in particular to improve non-Wacom tablets.
They don't provide a separate driver, because they prefer to provide
upstream patches to the kernel and the evdev X generic input driver
(and maybe to linuxwacom in the future), which is even better in my
opinion because it means you don't have to install anything else.
Anyway looking again your Xorg logs, it looks like your tablet has
been taken upon directly by the evdev X driver.

Strange thing though is that I did not find your tablet in the
DIGImend list either:

It is good that your tablet works well, but I would still suggest you
to contact DIGImend, tell them that your tablet works well out of the
box, though you have no idea why. And give them information about your
tablet (the Xorg output, then whatever they may ask). That may be a
good way to ensure that your tablet support is not an accident and
that it won't disappear in the future.

>> The problem may indeed come from the driver rather than Gimp,
>> especially if you use the wrong one (do you use the pen a lot outside
>> Gimp? Do you have similar issues elsewhere?). Same questions could
>> apply to GTK: if you have similar issues on other programs, but only
>> GTK ones, may be a bug in the GTK graphical toolkit.
> Similar problem happened in Mypaint, but the problem happened only when
> opening Preference dialog (sometimes), it never happened with Save dialog.
> Except for Mypaint, no other GTK application had this problem, eg. leafpad.

I see, Mypaint looks pretty similar to Gimp though. They may have very
similar piece of codes, so the same bugs. Or maybe that's something in
GTK related to graphical/drawing widgets only.

>> For this kind of tablet, you see only a pen input device? Not a pad
>> too? (I know this is a special type of machine, where the pad is also
>> the screen. So the question is maybe stupid, but as I cannot test
>> myself...)
> In "Input" dialog, there are only 2 device:
> (1) Virtual core xtest pointer
> (2) Waltop Tablet
>> I see you mention Gimp 2.4.7 and 2.6. Have you tried with 2.8 (last
>> stable version 2.8.2)? Maybe that's fixed there. That would be worth
>> installed (or compiled if Debian has no package yet maybe).
>> I would say that if there is no easy fix to your issue (like a
>> configuration one that we tried), nor a driver issue, installing the
>> latter version of Gimp should be the next step to diagnose.
>> Jehan
> Thanks for your reminding, I had tested this problem with gimp 2.8.2
> yesterday.
> The pen worked fine with gimp-2.8.2, I have migrated to gimp-2.8.

Good to know it is now fixed!

> Note: this "No response to tablet pen" problem only happened when meeting
> the About dialog (Help > About).

Do you mean it still happens in 2.8.2, but only in the about dialog?
That's better but probably proves the bug was coming from Gimp code, I
imagine. It must have been fixed in most important parts but not the

> Thanks you.

Enjoy your tablet. :-)


> Regards,
> Minshein0330
> _______________________________________________
> gimp-user-list mailing list
> gimp-user-list@gnome.org
> https://mail.gnome.org/mailman/listinfo/gimp-user-list
gimp-user-list mailing list

Reply via email to