Try replacing the single quote marks ' with double quotes " and also escaping 
the escaping the existing double quotes inside the single quotes:

"C:\Program Files\GIMP 2\bin\gimp-2.8.exe" -i -b "(let* ((image (car 
 (gimp-file-load RUN-NONINTERACTIVE 
 \"z:\test\26cf5abe-eaa1-4ddd-af04-3d9e59804ed2.png\" ...

I'm not sure if you will also have to escape the backslashes in file name paths 
as well:  \"z:\\test\\26cf5abe-eaa1-4ddd-af04-3d9e59804ed2.png\"

Kevin

> Date: Fri, 7 Mar 2014 10:52:27 +0100
> From: at_li...@gmx.de
> To: gimp-user-list@gnome.org
> Subject: [Gimp-user] Gimp Java Batch not working
> 
> Hi there,
> 
> I am new to Gimp and first I want to thank the Gimp community for such a 
> great application.
> 
> But here is my problem. I try to process images from within a Java 
> application. When I run the assembled batch command the gimp console 
> writes that the execution was successfull.
> 
> 
> But actually nothing happens. Here is my Java code:
> 
> 
> The resulting command line is:
> 
> "C:\Program Files\GIMP 2\bin\gimp-2.8.exe" -i -b '(let* ((image (car 
> (gimp-file-load RUN-NONINTERACTIVE 
> "z:\test\26cf5abe-eaa1-4ddd-af04-3d9e59804ed2.png" 
> "z:\test\26cf5abe-eaa1-4ddd-af04-3d9e59804ed2.png")))(drawable (car 
> (gimp-image-get-active-layer image))))(plug-in-sobel RUN-NONINTERACTIVE 
> image drawable 1 1 1)(gimp-file-save RUN-NONINTERACTIVE image drawable 
> "z:\test\test.png" "z:\test\test.png")(gimp-image-delete image))' -b 
> '(gimp-quit 0)'
> 
> Executing this directly from command line does not fix the problem. 
> Anyone a clue what I make wrong? Thank you in advance...
> 
> Kind regards,
> Andreas

                                          
_______________________________________________
gimp-user-list mailing list
List address:    gimp-user-list@gnome.org
List membership: https://mail.gnome.org/mailman/listinfo/gimp-user-list
List archives:   https://mail.gnome.org/archives/gimp-user-list

Reply via email to