My ISP doesn't carry the gimp group and I tried posting via
mixmaster but nothing gets on.   Is the ng moderated and
dumping anon posts? 

Could anyone please help me get a perl script invoked from HTML 
via the local server run Gimp? 

I have one conventional perl script that invokes other progs.
I was hoping to also launch The Gimp from within this script 
and then have it return control to the calling script to continue 
with getting the images into an html page.

The only thing I've been able to do is a separate standalone
script launch The Gimp, do some graphics and save them to disk 
before quitting. Then I have to restart the original script
to carry on with loading the saved images.

Also, this standalone script must run from a bash shell or from
a directly commanded bash script. It refuses to run either from 
any script via local served html.

Is there something Gimp-specific that Apache (1.3.2) must have 
installed? I get server errors but not much in the logs which 
might suggest scripting syntax but Gimp has proven finicky enough 
to undermine this hunch.

I've tried commands & syntax like...

   protocol error (1) at 
/usr/lib/perl5/site_perl/5.6.1/i586-linux/Gimp/Net.pm line 66.

   Gtk-WARNING **: cannot open display: 

   system('/usr/bin/gimp-remote -n /usr/...path/test.png');
   Gtk-WARNING **: cannot open display: 

   ... the above 2 are less valuable as I DON'T want display.

   eval {

   print"<a href="/usr/..path/gimpit.pl">gimpit.pl</a>";
   protocol error (1) at 
/usr/lib/perl5/site_perl/5.6.1/i586-linux/Gimp/Net.pm line 66.

   A bash script, otherwise able to launch gimpit.pl, invoked 
   from perl/html also results in
   protocol error (1) at 
/usr/lib/perl5/site_perl/5.6.1/i586-linux/Gimp/Net.pm line 66.

   which is here... (line #'s added for clarity)
    63  # this is hardcoded into gimp_call_procedure!
    64  sub response {
    65     my($len,$req);
    66     read($server_fh,$len,4) == 4 or die "protocol error (1)";
    67     $len=unpack("N",$len);
    68     read($server_fh,$req,$len) == $len or die "protocol error (2)";
    69     net2args(0,$req);
    70  }
   ... & a long long way over my head!  

Would appreciate any pointers.
Sorry if this is not exactly GIMP stuff, but the perl groups will
say it's not perl, and www will say it's apache... etc ;-) and who
would know better than Gimp users?


The original (including needs) script structure
sub dothings {
    blah... blah
#sub dosomeGimpPerChance {
#    blah... blah
sub dosomeotherthings {
    blah... blah

The standalone script structure
use Gimp qw (:auto);
use Gimp::Fu;
use Gimp::Util;
register "", "", "", "", "", "", "<None>", "*", "",
exit main();
  sub doit{
     blah.. NO show, only load, change & save.
  file_png_save($image, $final, $targp, $targp, 0,9,0,0,0,0,0);
  return ();
Gimp-user mailing list

Reply via email to