On Friday 19 April 2002 17:06, you wrote:
> On Wed, Apr 17, 2002 at 12:03:14AM +0000, As Signed 
> > Could anyone please help me get a perl script invoked from HTML
> > via the local server run Gimp?
> Run the script with -v to see gimp's error message. Protocol error
> 1 most probably means that gimp couldn't start. Most probably you
> don't have a valid DISPLAY in your environment.
> >    Gtk-WARNING **: cannot open display:
> Looks very much so. Set DISPLAY to a valid display and gimp will
> start.
> >    ... the above 2 are less valuable as I DON'T want display.
> Well, but gimp does ;)

Thanks for the rsponse.

I had since then posted to comp.graphics.apps.gimp
and got much the same advice.  I installed Xvfb and think I got it
running but it did not help.   I also got a bash script to run a 
Script-Fu I threw together but found myself back with the same 
protocol error when I tried to get that bash to run from an HTM page
though it wasn't exactly what I wanted (Script-Fu, Perl-Fu nocando).

So I thought why don't I just install Gimp 1.3.5 which also went 
fairly well right up to the point of trying to install Pango or 
whatever which gave me nothing BUT error messages.  

I GAVE UP and created a KDE menu item to run my standalone perl
script.   Now when I run the primary perl script from an HTM page it
writes a data file on the first run and then fails to load an image 
yet to be created.   I then run the standalone perl script via the 
menu entry (or shell) and that gets Gimp to do its thing with the
data.  Then I run the main script again and it loads the created 
image.  In short 3 clicks instead of 1.

I  hope that 1.3.5 will soon be a part of a SuSE distribution and 
maybe then I'll take another shot at embedding the standalone into
the primary script.  For now I just can't afford to be chasing 
rainbows.   My programming is too limited, especially when it 
comes to figuring out why a standalone perl script that CAN and 
DOES get Gimp to compose an image and save it when run from
shell cannot do the same (and no more) from an HTM page.

I don't need Gimp to feed the output to the calling script, just to
save it to disk and the script can take it from there.  Someone
said on the ng long ago that this error was likely an Apache or
HTTPD or Perl problem.  I still wonder.  Maybe it's just my perl 
Gimp-user mailing list

Reply via email to