--- Carol Spears <[EMAIL PROTECTED]> wrote:
> Jeff!  Hello!
> 
> this <u>has to be</u> a problem with TheGIMP!
> 
> would you like for me to file the bugreport?
> 
> carol

Hi all,

This is not a problem with the GIMP, more likely GTK, glibc AND/OR
gcc itself.  Try compiling the following test code (the contents of
line 22 of parasitelist.c, the file that failed):

#include <gtk/gtk.h>

int main (void) {
  /* Do Nothing */
}

saved as 'segfault.c', with the following gcc command:

gcc -Wall -g segfault.c -o segfault `gtk-config --cflags` \
    `gtk-config --libs`

I suggest that updating gcc and gtk to the latest STABLE versions
should be enough.  I have had problems with gcc on Redhat before,
which couldn't compile a later version of gcc!

In the past, Redhat has used the latest unstable version of gcc for
their build.  The fact that gcc is segfaulting does suggest that it
is a good candiate to update. If you 'make clean' and retry, does
the same error appear?

Jonathan Paton

---ORIGINAL MESSAGE---
> On 2003-06-14 at 2224.01 -0700, Jeff Trefftzs typed this:
> > Hi All -
> > 
> > I just downloaded and began compiling the latest stable gimp, 1.2.5. 
> > Configure worked properly, but the compile failed with the following
> > output:
> > 
> > gcc -DHAVE_CONFIG_H -I. -I. -I..
> > -I.. -I../intl -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2
> > -I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/local/include
> > -DLIBDIR=\""/usr/local/lib/gimp/1.2"\" -DLOCALEDIR=\""/usr/local/share/locale"\"
> > -DREGEX_MALLOC -DG_LOG_DOMAIN=\"Gimp\" -DGTK_DISABLE_COMPAT_H  -g -O2 -Wall -c
> > parasitelist.c
> > In file included from
> > /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/include/limits.h:132,
> >                  from
> > /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/include/syslimits.h:7,
> >                  from
> > /usr/lib/gcc-lib/i386-redhat-linux/3.2.2/include/limits.h:11,
> >                  from /usr/lib/glib/include/glibconfig.h:9,
> >                  from /usr/include/glib-1.2/glib.h:66,
> >                  from /usr/include/gtk-1.2/gdk/gdktypes.h:33,
> >                  from /usr/include/gtk-1.2/gdk/gdk.h:31,
> >                  from /usr/include/gtk-1.2/gtk/gtk.h:31,
> >                  from parasitelist.c:22:
> > /usr/include/limits.h:-6358: internal error: Segmentation fault
> > Please submit a full bug report,
> > with preprocessed source if appropriate.
> > 
> > Any ideas what might cause this?  I'm on RH9, with a previously
> > installed Gimp-1.2.3.  Is it my system (not impossible) or is this a
> > real bug?
> > 
> > --Jeff

=====
#!perl
$J=' 'x25 ;for (qq< 1+10 9+14 5-10 50-9 7+13 2-18 6+13
17+6 02+1 2-10 00+4 00+8 3-13 3+12 01-5 2-10 01+1 03+4
00+4 00+8 1-21 01+1 00+5 01-7 >=~/ \S\S \S\S /gx) {m/(
\d+) (.+) /x,, vec$ J,$p +=$2 ,8,= $c+= +$1} warn $J,,

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/
_______________________________________________
Gimp-user mailing list
[EMAIL PROTECTED]
http://lists.xcf.berkeley.edu/mailman/listinfo/gimp-user

Reply via email to