Sven Neumann wrote:


BandiPat <[EMAIL PROTECTED]> writes:

The new Gimp compiled fine today and installed. Upon trying to run
it though, it got to a load point and just died. I ran it from the
shell to check for more messages and found it doing a Segmentation


Updating fontconfig to version 2.2 should fix the problem for like it
fixed it for everyone else who reported this problem so far.


Thanks for posting a link to this bug report. I'm seeing a similar problem at startup but it's not font related and is related to the "tool-safe-mode" plugin:

[EMAIL PROTECTED]:~/build/gimp-1.3.20$ gimp-1.3
This is a development version of the GIMP
Debug messages may appear here.

Testing CPU features...
 mmx     : yes
 3dnow   : no
 mmxext  : no
 sse     : no
 sse2    : no

gimp_composite: use=yes, verbose=no +mmx
added locale domain "gimp20-script-fu" for path "(null)"
/usr/lib/gimp/1.3/plug-ins/tool-safe-mode: fatal error: Segmentation fault
/usr/lib/gimp/1.3/plug-ins/tool-safe-mode (pid:32142): [E]xit, [H]alt, show [S]tack trace or [P]roceed: S
#0 0x404bd304 in g_on_error_stack_trace (
#1 0xbffff394 in ?? ()
#2 0x404bd221 in g_on_error_query (prg_name=0xbffff394 "32142")
#3 0x400e5413 in gimp_plugin_sigfatal_handler (sig_num=1079078920)
#4 <signal handler called>
#5 0x40593e0b in strlen () at strlen:-1
#6 0x0804929a in safe_mode_init () at tool-safe-mode-plug-in.c:52
#7 0x400e462c in gimp_main (argc=6, argv=0xbffff8c4) at gimp.c:386
#8 0x080492db in main (argc=1, argv=0x1) at tool-safe-mode-plug-in.c:68
#9 0x4052dca6 in __libc_start_main (main=0x80492c0 <main>, argc=6,

I'll install fontconfig 2.2.0 and see if that helps any.




_______________________________________________ Gimp-user mailing list [EMAIL PROTECTED]

Reply via email to