Ok, first off, thanks to all who have answered so far.

The situation at present: I have compiled and installed gimp 2.2.4 without print option, then ran ldconfig because the readme said so, then compiled and installed gutenprint 5.0 beta 3 with gimp, cups, foomatic, and ghostscript. All without problem.

I restarted cups with the printer switched on (an Epson CX5400) and modified the printer to use the recommended gutenprint plus cups driver for the same printer.

Sadly, the problem still persists. I have started gimp from a terminal in the hope that some error message would appear, but nothing. I can open the image, select 'print', then I get the gutenprint dialogue. I set all the values to what I need (but I've also tried the standards and other values), press print, and the dialogue disappears, the 'printing' bar underneath the picture grows to 100%, and then silence. No error, the cancel button and gimp as a whole react normally, but the printing bar remains at 100%. No error in the terminal, nothing.

Opening the CUPS configuration page in my browser, there are no print jobs in progress, as if nothing was sent to CUPS. The printer is idle. A CPU monitor does not show any agitation there - top tells me there are a couple of 'print' and 'lp' tasks running:

28384 bitpicke  16   0 16764  11m 6756 S  0.0  1.7   0:00.00 print
28385 bitpicke  15   0  3300 1340 1056 S  0.0  0.2   0:00.22 lp
28386 bitpicke  19   0 16764  11m 6756 S  0.0  1.7   0:00.00 print
28550 bitpicke  17   0  1868  512  436 S  0.0  0.1   0:00.00 gnome-pty-helpe
28551 bitpicke  16   0  4028 1724 1264 S  0.0  0.2   0:00.06 bash
28678 bitpicke  16   0 16064  10m 6752 S  0.0  1.6   0:00.00 print
28679 bitpicke  15   0  3300 1340 1056 S  0.0  0.2   0:00.21 lp
28680 bitpicke  19   0 16064  10m 6752 S  0.0  1.6   0:00.00 print

But this is very near the end of the list, only the idle browser in the background is even lower. They never do much.

In /var and its subdirectories the only things I can find which have something to do with the print attempt are two 13 MB temp files with (possibly) hexadecimal names in /var/tmp - they were made within four minutes of each other about after I started the printing process. I later tried another printout of a different file, and a new file turned up there. Of course that didn't print either.

I can then cancel the printing process, close the image, close gimp, all without any error whatsoever.

That's all I know. Does anyone have any suggestion what I can do next in order to make gimp actually print something?

Gimp-user mailing list

Reply via email to